ATV1 installation issues

Hi there, I got an Apple TV 1st gen in 2019 and tried out OSMC for a little bit, and didn’t have much success. I recently dug it back out and decided to give it another go as a media center device. I’ve been trying the past few days to get OSMC installed onto the original 160GB drive, and I also tried a 30GB drive. The closest I was able to get was getting OSMC setup running off of a flash drive with the HDD disconnected, and that was after leaving it running overnight.

My issue is, most of the time after it goes through the initial installation with the Tux/Apple TV logo and reboots the screen just stays black. I’ve tried 3 different flash drives, and almost all the different versions on the OSMC installer, as well as trying with Rufus and Win32DiskImager.

Is there a more reliable way of installing OSMC without hitting so many walls?

I’m pretty sure the osmc support for ATV 1 ended way earlier than 2019

Apple TV 1 was good product in its time but all development in the Kodi space ended more or less in August 2017. Rather buy a Vero 4K+ or wait a bit to buy a Raspberry PI 4.

Yep, 2017

I would but this project was mostly just so I could have a play with some older hardware, and to repurpose something old so I don’t have to shell out any cash. I have been getting it running intermittently by being very patient with the installer, however.