ATV1 Internal WiFi adapter (how to use it)-hopefully instructions

Hello, I’m new to OSMC and recently installed the newest image as of February 2017 in USB style on my apple tv 1. I can no longer use my internal WiFi and like many others I would like to and am content with sd formats… Don’t want a crystal hd card at this point nor do I want to have to buy a USB hub & WiFi dongle or an ethernet to WiFi bridge just to use the unit…

Since the install I’ve spent hours hunting & pecking around a bunches of threads in here as well as googling various aspects with no real clear cut and dry solution or instructions… I get that the CHD card is the best thing since sliced bread and way to go but just want the unit working in simple configuration. My internet isn’t fast enough for good hd anyway as I’ve tried, sd stuff however plays fine!

Several old threads mentioned the driver/firmare/patch etc? for internal WiFi would be handled in next update (that was over a year ago). So my questions are these…

  1. Is it really that hard to put the necessary firmware in or will that mess up the install for those who use a CHD card?

  2. Can someone please explain how to enable the internal card to be found by OSMC and be used. I’m not a programmer or coder, I’d no idea how to SSH but googled that and installed on windows an SSH client called puTTY? from there I’ve no clue. All the threads say search topic it’s been explained. I’ve been through a ton of them and they all assume most of know how to ssh and sudo or sodu but I’m not even good at sodoku. :flushed:

Some instructions simply said install b43 cutter, another says use installer. Then I found this which I’m not sure what to do with? or how it’s typed, is there spaces, is each a seperate command etc?
sudo apt-get update
sudo apt-get install firmware-b43-installer
sudo reboot

Please if someone can help spell this out as I know I’m not the only one who’d like to use the internal WiFi and has no sudo/sodu/sodoku experience. Thanks in advance

I’ve just added support now. I was told before that b43-fwcutter was necessary; but that was apparently not sufficient. I don’t have the old card anymore, so could never test. If firmware-b43-installer is all that’s necessary, then it’ll be fixed in this commit:

This change will be available in the April update, or via jessie-devel if you update via Ethernet.

Please keep in mind AppleTV is very much approaching end-of-life and I will soon discontinue support for it.



1 Like

Execute them after login in via SSH.
They are three different commands but you just can copy/paste them as is as long as the line feed is also copied.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

1 Like

Thank you So much Sam, having pecked around tons I can only wholeheartedly appreciate and thank U all for what U do and have done!..!

I know the ATV1 is nearing EOL n all help to now is gracious. Can I ask how does one use “committ:” packages at github? I’m sorry for stupid questions… Maybe this is a new thread?
Sorry n thanks

Thanks much fzinken… So they are 3 different commands but can be copy/pasted in once in SSH. Same as you are seing with spaces etc.?

"They are three different commands but you just can copy/paste them as is ((( here’s where I’m unsure))) as long as the line feed is also copied.

What’s the line feed? I feel I’m missing somethin.?
Thank you so much

Just copy and paste them as they are dsiplayed with spaces and new lines.

“line feed” = “New Line” = Enter at the end of a line

fzinken, Awesome and thank you! I’ve not done anything command line etc since basic n dos too many forgotten years ago but assumed everything is typographically-critical… every character or space is fail if not right and I really had no clue here!
I’m going to try now…

I think it worked, now to check apple tv and close ssh window I guess. Maybe reboot it manually and see what we shall see. lol

By Golly I think We’ve got it!!! KUDOS and thanks to you both and all of you that help make OSMC Great! Some guidance and this got it going!

Connected to wifi after power cord yank/reboot and closing windows comand program. Fired back up and went to (My OSMC>Networks) rest was normal everyday.

THANK YOU!!! I’ve been make shift using my computer’s network sharing feature thus far to even use my ATV1 since the install of OSMC and to have it back on WiFi is (AS-IS) is like the holy grail…

Hopefully this thread will help others as much and I’ll work on trying to repost a streamlined bit of it for reference. :smiley:

Do not yank the power chord or you will have problems updating