Audio bug: Pause button has side-effects


#1

Hi,

Just noticed that when playing a video or audio track, there are two audio issues when you press the PAUSE button.

Firstly, once PAUSE is pressed, the GUI sounds no longer work (while you navigate the menus and folders).

Secondly, when you begin to play a new track, you get a fraction of a second of the old track, plus the GUI sound, then the new track begins. Quite an unpleasant effect, especially if the old track was loud.

If you press STOP rather than PAUSE, then all is well - but of course then you won’t have the option to resume the old track.

Not sure if it’s always done this, or was in some way triggered by me adding an SMB share containing music (FLAC format). But it also happens when I play MKV videos over SMB, so it’s not just audio mode that triggers it.

I did wonder if it was my new SPDIF connection making this happen, but it persists over the HDMI audio if I switch the SPDIF output back to analog.

I also played with the settings relating to keeping audio devices alive. But setting “always” or “never” doesn’t seem to affect this.

It would be nice if the PAUSE button could be made to work like the STOP button, only without losing the current playback position.

Thanks for any pointers,

  • Martin

#2

Hi Martin,

Thanks for the report.

Can you confirm whether passthrough is enabled when this occurs?
We’re working on some audio improvements for Vero 4K. They may also benefit the Vero 2 as well.

Can you post a full set of logs when this happens? I want to see how the kernel is handling audio.

Sam


#3

Passthrough is disabled.

I’ll prepare some logs shortly.

Thanks!


#4

Log URL posted as private message.

Thanks for the speedy response.