Audio connection problems Vero 4K to soundbar


I’ve got a new soundbar, Samsung HW-Q950T, which is causing me quite a bit of trouble when connecting to my Vero 4K. I’m not sure if the problem is with OSMC/Vero or the soundbar, but I thought I might ask here first.

I’m connecting the Vero 4K via HDMI to one of the HDMI inputs on the soundbar (and then a HDMI out to the Sony OLED TV I have, connected in the eARC port). However, when I look at the audio settings (Settings/Audio), sometimes I haven’t got a HDMI option, only the Pulseaudio and OSMC Streaming option. I can use this to get sound from my soundbar but not the correct audio format on the movie och tv show.

If I reboot the Vero, sometimes I get an option to use AML-M8AUDIO HDMI connection which means I can enabled passthrough in Kodi and enable all HD-Audio formats (which the soundbar supports). However, if I use this option, I still don’t get audio on certain file, including Dolby Atmos (or even DD 5.1), DTS-EX, TrueHD even though the soundbar supports it.

Sometimes after a Vero reboot I (once in a while) get a similar HDMI option in the settings, but this is called “Default - AML-M8AUDIO” or something similar (I can’t get that option right now, regardless on how many times I restart Vero). If I pick this option I can get Dolby Atmos (displayed on the soundbar as the input signal) and other HD sound formats to work correctly.

Is there anything I can/should do in the Kodi settings to be able to get correct HDMI audio connection and, if so, what is it? As I said, I’ve tried to restart Vero multiple times to see if the option gets available, and I’ve also tried to unplug Vero and starting it up, removed the HDMI cable and reinserting it both when the soundbar is on/off and when Vero is on/off, but I can’t seem to find a certain way to recreate the starting order to make sure I can get an option to pick a correct HDMI audio connection.

Is this something that is a problem on the soundbar or the Vero? Has anyone else had this problem?

Pulseaudio is not installed by default. If you are using bluetooth audio, then we recommend you remove pulseaudio and use bluez-alsa instead. To remove pulseaudio and the deprecated a2dp package:

sudo apt-get remove a2dp-app-osmc
sudo apt-get remove --purge pulseaudio

Apart from that, it seems strange you’ve only got this issue since connecting in the soundbar. That should not affect the options you see in the audio settings. Let us know if removing pulse fixes things.

Thanks for the answer @grahamh, it seems to have solved the issue (at least for the time being). I ran the commands you suggested and uninstalled PulseAudio and rebooted, and when the Vero 4k was up and running, this was the only audio options:

I’m still not sure what the difference between the two options are, because if I choose “Default” my soundbar will detect Dolby Atmos (and display the input source as just that) but if I choose AML-M8AUDIO, HDMI the soundbar will still play audio but not detect Dolby Atoms (and some other HD-Audio sources). However, since it seems to be working with the Default option, I’m good at the moment.

Thanks again for the help to fix this problem!

You’re welcome. The HDMI option should be the same as ‘default’ for HD audio. I’ll look into that if that behaviour persists with kernel 4.9, but anyway it’s not necessary to select HDMI ever as you have found.