Audio Cutting Out On Certain Videos

Vero 4k+. Not sure how to add the logs into the chat so just provided the link.

I use my Vero with an external hard drive to play my media. Everything was fine until yesterday until I tried to play an episode from an anime. The audio would not be heard until like 15 seconds in, then would cut out again a few seconds later. Tried with another episode and same problem. Went to an older anime with Japanese audio and worked fine. When to a few foreign movies with multiple audio tracks and worked fine. Tried a couple more new anime and same problem. I assumed it was a codec issue since I just got my Vero and it had not been updated yet so I update it and still the same problem. Messed around with my audio channel set up to try to get it to work but no luck. These same episodes play fine on a Western Digital Media Player. Any ideas?

Yes. There is an issue with playing video at 4k resolution and 44.1kHz audio. If you set your desktop to 1080p24 instead of 2160p24 (recommended anyway) it should play OK.

Awesome that seems to have done it, thank you. Stupid question but will this effect the quality of the video being played?

We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

The first video you played was 720p. I doubt you will see much difference with playing it at 1080p (with the TV upscaling that to 4k which is trivial).

Awesome thank you. The question was more geared towards 4k content which I do have. Will it limit the quality or will the tv handle the rest? Would you recommend switching the UI back to 4k before playing one of the 4k movies?

If you use the recommended settings (as posted by @ActionA ) then the Vero 4K+ will automatically switch to 4K output for 4K videos, and play everything else at 1080p. So both 1080p and 4K videos will play optimally.

This is slightly suboptimal for videos with resolutions below 1080p, because (as @grahamh says) these will be upscaled twice, once by the Vero and once by the TV - but in practice most people probably won’t see any difference. (If you care about optimising for videos below 1080p resolution then investigate the whitelist function).

I wouldn’t worry about it. If you want, you can change the audio settings to Fixed and 48ks/s and play all your 4k files at 4k. It’s just 4k video + 44.1kHz PCM audio that’s the problem.

The good news is that this problem has gone away with the new kernel and Debian Bullseye that should be released ‘real soon now’.