Audio Delay at video start


Just got my Vero2, was running osmc on a Raspberry Pi 3 perviously, I love it, my only issue is I experience a delay in the sound when I start a video. It catches up fine and ends up not being an issue because it runs in sync once it starts. There is just a gap of 2-3 seconds where the video is playing without any audio. The delay seems less extreme since I got my Vero2 so I’m thinking it’s just a CPU issue. Just curious if anybody else experiences this and if anyone has found a fix.

Thanks in advance!

A possible solution is to go into Settings->Audio and change the setting which causes the Audio channel to be stopped when idle for 1 minute - change it to never.


Do you have a small file that can reproduce the problem?
Are you using passthrough? There can be a slight audio gap when the signal changes, same with Adjust Refresh Rate.

@actiona’s solution may also help


I must have a different version but I went Settings–>System–>Audio Output and found “Keep Audio Device Alive” it was set to 1min so I changed it to Always. Went right back out and started a file and had the delay.

You should always reboot after making such changes before you assume that they don’t work. May not make a diff here but a simple piece of advice.

@sam_nazarko I will look for a smaller file. I am not using passthrough. The issue happens with literally every video being played though, I have not tested directly from USB or the SD card, but from my NAS it will happen on every file regardless of size it also happens when I am playing videos through the add-ons.

Is it mounted via SMB or NFS?
Sometimes an fstab mount will prove better.

There is a new Ethernet driver for Vero 2. It will land in this month’s update and may improve your situation.


The vero is using sftp to connect to it, is there a more preferable option?

Great, can’t wait for the new driver.

SFTP will be a bit slow.

You should look at a better protocol.

Any suggestions?

NFS would be best and your NAS device should support it

I have the exact same issue with files that have DTS enabled.

Works on Pi fine, just not on Vero 2.

Have been private messaging Sam directly about this and it’s got better but still not right.

Hi Martin

I knew you had some sync issues but didn’t realise you had some files that quickly resolve after three seconds of playback or so.

If OPs are also DTS encoded then worth us taking a look at. Make sure you stay up to date on Krypton builds for best results.


Settings>Video>Playback>Pause during refresh rate change

Does this setting have any affect on the problem?

Yeah in the last few builds the sync is now good (on all files) after taking 2-3 seconds to catch up.

I can live with that as long as it does playback in sync :smiley:

started NFS, it seems to be better but still not perfect.

@Dilligaf does this change just delay the start of video until the audio is playing?

I’m not sure. I assume that it delays so the TV and whatever else have time to switch.

Hi there,

I have the same issue too on Rpi 2.
I will try to change the mentionned settings.

I had the same issue try:

Settings -> Player Settings -> Videos -> Adjust Display Refresh Rate -> Off

It fixed the delayed audio on my start and stop when playing videos and stopping them.