Audio delay when playing movies


I have become a big fan of OSMC but there is one problem I have not yet found a solution for. This is that when playing movies, there is a slight delay between video and audio, i.e. audio is lagging behind. Probably in the range of 200ms or so. The delay remains stable during video playback.

I tried several changes to the audio settings but saw no improvement. HW is a raspberry B+, OSMC newest update, HDMI output.

In particular: is there any setting so influence the general audio/video timing offset?

Any help appreciated!

Bring up OSD (enter/ok key) when playing a video and in the audio page is an audio offset setting.
You can select “set as default for all videos” if you want this offset to apply to all videos.

Thanks - that helped!

But shouldn’t really be needed.

There must be something unusual about your setup because lip sync over HDMI is perfect for me with no adjustments…200ms is a lot.

I’ve got the same problem since the Jarvis update… My HT setup is based around a somewhat older receiver without HDMI-inputs and lipsync correction. Due to this, there’s an 175ms lag between the image and audio (the audio is ahead of the image).

This was never a problem, because I could correct this in the audio-menu when playing a video (it was stored as a default setting for all video’s), but with Jarvis this option is gone… :worried:
I do have an “Audio DSP…” option, but that doesn’t do anything (it doesn’t open/respond).

Who can help me with this? There’s nothing more annoying to me than a lipsync problem… The difference is big enough for me to notice…

It would help if you said what platform you are running on… and what skin you are using…

The audio sync option is still where it has always been - go into the on screen controls during video playback and choose audio settings, it’s one of the listed options there. There is an option to save any setting as default at the bottom.

Sorry, forgot to mention…

I’m on a Raspberry Pi2, my default skin is Amber, but I’ve also tested Confluence and the default OSMC-skin.

I’m not at home at the moment, but I’m fairly sure it isn’t there where it used to be… I’ve searched in the audio settings in de on-screen controls, but can’t find it…

Could this have something to do with the Hifiberry Digi I’m using? (it wasn’t an issue with previous versions, but I’ve noticed that it sometimes interferes with some default options…)

It’s a standard feature that has been in Kodi for a long time and is definitely still there - I use it myself in Jarvis.

A screenshot demonstrating its absence would be helpful. Remember not all skins fully support Jarvis yet - check to see whether Amber is supported yet.

Just installed Amber on Jarvis, I see the option:

1 Like

Thanks, as soon as I’m home I’m going to check if this option is still there… But I’ve seen this menu yesterday and I’m almost 100% sure the option wasn’t there. Like you’ve said, it should be in the same place it always was (and I’m used to setting it up in Kodi…)

I’ve tried it, and in one install (a Pi2 without a Hifiberry and a vanilla install of OSMC), the option is visible:

But on de Pi2 with a Hifiberry (my primary mediaplayer), it isn’t:

An other interesting point is that my vanilla install doesn’t show Audio DSP, while my primary install (with the Hifiberry), it does…

Update, I’ve found the problem, though I’m unsure about the cause… In my guisettings.xml the line
<dspaddonsenabled default="true">false</dspaddonsenabled>
got set to it’s default “true” value. This option is nowhere to be found in the settings menu of Kodi, but turned out to be the cause of my problem…

It’s now set to false and everything is working just fine.

Glad you found the problem. Default=true actually means this is the default setting on a fresh install. The current setting as shown above is actually set to false.

I know what “Default=true” means :wink: I’ve been editing Kodi’s/XBMC’s xml-files since way before OSMC was created.

All I know is that something went wrong with the base linux install on my Pi, causing Apt to stop working. When I fixed that, Kodi was updated to Jarvis and all kinds of things got broken (causing an bit of a cranky girlfriend… :fearful:)
Now I think about it, one of the fixes was to remove the guisettings.xml (my skin was broken, causing kodi to crash). That was probably the moment the setting was altered to the default setting of DSP active…

That would be it.