Audio distortion with Samsung SoundBar + Vero remote / HDMI

Hi,

I have a small problem with my Vero 4K+, I can’t set the volume of my soundbar with Vero Remote (same for TV remote by the way).
So if I increase or decrease the volume for music tracks or movies, a weird distortion happens, sounding like too much loudness or not enough loudness. You can still listen but It happens everytime, and you always hear it.
The problem doesnt occur with spdif, but only with HDMI.
I can use the dedicated samsung remote, it s working fine with it, but since I do everything with Vero remote, I’m searching for a solution to make that work with it.

Equipement: sony TV kd43xf2096, samsung hw-N550 3.1ch SoundBar, vero 4k+. Linked with HDMI Arc.

I think the problem could be, after reading other posts, the hdmi cables but before buying, can someone please confirm?

I tried multiple various settings in system audio settings, nothing is making any change.
CEC is working fine for standby and lauching both TV and SoundBar.

Please set your output to best match first.

Rather than a screenshot, can you record what it sounds like? Do you get distortion only when changing volume? I’m puzzled by what you get when you decrease the volume.

Is the vero connected to the soundbar (preferred) or the TV?

Best match in audio setting do not fix the issue.
Vero is connected to the Soundbar.
It’s only when changing volume yes.

I recorded what it sounds like on this audio file.

  • I start with good sound quality (untouched playing) then you quicly hear the “too-much-loudness” as decreasing progressively the volume.
  • then pressing volume up generates a “flat sound” like bass are cuted. This time only one remote press and sound is instantly changed.

As always, one volume press of the samsung remote recalibrates the soundbar.

Thank you

Change PCM to HDMI

I’m guessing this has to do with a function on the soundbar being activated through CEC which is not a normal volume control. It happens with both Vero remote and TV remote - suggests it’s an issue in the soundbar. It doesn’t happen with S/PDIF - expected since S/PDIF doesn’t support CEC and the Vero remote will be changing the volume in Kodi (you should see a symbol top centre of the screen showing the volume), not in the soundbar.

Have a close look at the soundbar manual. Does the soundbar have an on-screen display that might reveal something?

Thanks for the help again, but changing PCM to HDMI did not fix it unfortunately.
For samsung soundbar, CEC is called “Anynet+”. I have to activate it for volume control with Vero and TV remote (and for cec shutdown and launch). I have not seen anything relevant in the sounbar manual.
Sending the log file hoping it makes sense. First I used vero remote, then “CecLogMessage” refers to samsung remote which i used for volume.

18:56:42.657 T:4080505424   DEBUG: LIRC: Update - NEW at 2573329:72 0 KEY_VOLUMEDOWN_UP linux-input-layer (KEY_VOLUMEDOWN_UP)
18:56:42.876 T:3939496704   DEBUG: CecLogMessage - << 15:45
18:56:42.898 T:4080505424   DEBUG: LIRC: Update - NEW at 2573569:72 0 KEY_VOLUMEDOWN linux-input-layer (KEY_VOLUMEDOWN)
18:56:42.898 T:4080505424   DEBUG: OnKey: rightctrl (0xd1) pressed, action is VolumeDown
18:56:42.938 T:4080505424   DEBUG: LIRC: Update - NEW at 2573609:72 0 KEY_VOLUMEDOWN_UP linux-input-layer (KEY_VOLUMEDOWN_UP)
18:56:42.974 T:3939496704   DEBUG: CecLogMessage - << 15:44:42
18:56:43.178 T:4080505424   DEBUG: LIRC: Update - NEW at 2573850:72 0 KEY_VOLUMEDOWN linux-input-layer (KEY_VOLUMEDOWN)
18:56:43.178 T:4080505424   DEBUG: OnKey: rightctrl (0xd1) pressed, action is VolumeDown
18:56:43.180 T:3939496704   DEBUG: CecLogMessage - << 15:44:42
18:56:43.218 T:4080505424   DEBUG: LIRC: Update - NEW at 2573889:72 0 KEY_VOLUMEDOWN_UP linux-input-layer (KEY_VOLUMEDOWN_UP)
18:56:43.436 T:3939496704   DEBUG: CecLogMessage - << 15:45
18:56:43.617 T:4080505424   DEBUG: LIRC: Update - NEW at 2574289:72 0 KEY_VOLUMEDOWN linux-input-layer (KEY_VOLUMEDOWN)
18:56:43.618 T:4080505424   DEBUG: OnKey: rightctrl (0xd1) pressed, action is VolumeDown
18:56:43.620 T:3939496704   DEBUG: CecLogMessage - << 15:44:42
18:56:43.658 T:4080505424   DEBUG: LIRC: Update - NEW at 2574329:72 0 KEY_VOLUMEDOWN_UP linux-input-layer (KEY_VOLUMEDOWN_UP)
18:56:43.876 T:3939496704   DEBUG: CecLogMessage - << 15:45
18:56:44.456 T:4080505424   DEBUG: LIRC: Update - NEW at 2575128:73 0 KEY_VOLUMEUP linux-input-layer (KEY_VOLUMEUP)
18:56:44.456 T:4080505424   DEBUG: OnKey: leftctrl (0xd0) pressed, action is VolumeUp
18:56:44.457 T:3939496704   DEBUG: CecLogMessage - << 15:44:41
18:56:44.496 T:4080505424   DEBUG: LIRC: Update - NEW at 2575168:73 0 KEY_VOLUMEUP_UP linux-input-layer (KEY_VOLUMEUP_UP)
18:56:44.711 T:3939496704   DEBUG: CecLogMessage - << 15:45
18:56:44.775 T:4080505424   DEBUG: LIRC: Update - NEW at 2575447:73 0 KEY_VOLUMEUP linux-input-layer (KEY_VOLUMEUP)
18:56:44.775 T:4080505424   DEBUG: OnKey: leftctrl (0xd0) pressed, action is VolumeUp
18:56:44.804 T:3939496704   DEBUG: CecLogMessage - << 15:44:41
18:56:44.855 T:4080505424   DEBUG: LIRC: Update - NEW at 2575527:73 0 KEY_VOLUMEUP_UP linux-input-layer (KEY_VOLUMEUP_UP)
18:56:45.055 T:3939496704   DEBUG: CecLogMessage - << 15:45
18:56:45.135 T:4080505424   DEBUG: LIRC: Update - NEW at 2575807:73 0 KEY_VOLUMEUP linux-input-layer (KEY_VOLUMEUP)
18:56:45.135 T:4080505424   DEBUG: OnKey: leftctrl (0xd0) pressed, action is VolumeUp
18:56:45.154 T:3939496704   DEBUG: CecLogMessage - << 15:44:41
18:56:45.255 T:4080505424   DEBUG: LIRC: Update - NEW at 2575927:73 0 KEY_VOLUMEUP_UP linux-input-layer (KEY_VOLUMEUP_UP)
18:56:45.405 T:3939496704   DEBUG: CecLogMessage - << 15:45
18:56:48.127 T:3939496704   DEBUG: CecLogMessage - >> 01
18:56:48.127 T:3939496704   DEBUG: CecLogMessage - << POLL: TV (0) -> Recorder 1 (1)
18:57:03.127 T:3939496704   DEBUG: CecLogMessage - >> 01
18:57:03.128 T:3939496704   DEBUG: CecLogMessage - << POLL: TV (0) -> Recorder 1 (1)
18:57:05.624 T:3808879360   DEBUG: Thread JobWorker 3808879360 terminating (autodelete)
18:57:18.127 T:3939496704   DEBUG: CecLogMessage - >> 01
18:57:18.128 T:3939496704   DEBUG: CecLogMessage - << POLL: TV (0) -> Recorder 1 (1)
18:57:33.128 T:3939496704   DEBUG: CecLogMessage - >> 01
18:57:33.128 T:3939496704   DEBUG: CecLogMessage - << POLL: TV (0) -> Recorder 1 (1)
18:57:48.123 T:3939496704   DEBUG: CecLogMessage - >> 01
18:57:48.123 T:3939496704   DEBUG: CecLogMessage - << POLL: TV (0) -> Recorder 1 (1)
18:58:03.128 T:3939496704   DEBUG: CecLogMessage - >> 01
18:58:03.128 T:3939496704   DEBUG: CecLogMessage - << POLL: TV (0) -> Recorder 1 (1)
18:58:18.123 T:3939496704   DEBUG: CecLogMessage - >> 01
18:58:18.123 T:3939496704   DEBUG: CecLogMessage - << POLL: TV (0) -> Recorder 1 (1)

Could you test this with deactivated dynamic range control of your soundbar? Look at the manual how to switch it off.

DRC on/off and SURROUND on/off gives no result.
Re-linked the subwoofer, changed hdmi arc connecting vero to tv before soundbar, same problem.
I’ll check a different pair of hdmi cables.

Tried new hdmi cables. Sound gets messed up when controlling volume with Vero remote.
Same thing with using TV playing music to soundbar + controlling volume with TV remote.
Must be the samsung soundbar which is not fully compatible with CEC.
Will ask samsung support.

Reading a manual of your soundbar I struggle upon page 25.
In what mode is the soundbar at the moment?

  • “SAMSUNG-TV REMOTE” (Default mode)
  • “OFF‑TV REMOTE”
  • “ALL‑TV REMOTE”

What is your intended function when using the TV’s remote control to manipulate volume?
Change the volume on the Vero, on the soundbar or even both?

I found a compromise which is turning off CEC.
I control volume with kodi remote on the kodi audio output, and I shut down soundbar+tv with an extension cord.
I can get rid of CEC problems, samsung support cannot fix it and other cables neither.
Thanks for the help anyway!

I found that when I use the terminal and send volup/voldown libcec commands, it’s working good, the audio stay clean. Is that a good track?
Hope I’d know how make it useful inside osmc, also for audio passthrough option which get worse without cec in my system. Tried some research at libcec github but I’m quickly stopped by my lack of coding knowledge.

Maybe something noteworthy, if I shutdown and unplug tv the osmc remote doesnt control volume anymore. I think I’ve tried all tv settings for audio.

Libcec scan:

osmc@osmc-Gilbert:~$ echo scan | cec-client -d 1
log level set to 1
No device type given. Using ‘recording device’
CEC Parser created - libCEC version 4.0.4
no serial port given. trying autodetect:
path: /dev/aocec
com port: AOCEC
opening a connection to the CEC adapter…
waiting for input
requesting CEC bus information …
CEC bus information

device #0: TV
address: 0.0.0.0
active source: no
vendor: Sony
osd string: TV
CEC version: 1.4
power status: on
language: fre
device #1: Recorder 1
address: 3.1.0.0
active source: no
vendor: Pulse Eight
osd string: CECTester
CEC version: 1.4
power status: on
language: eng
device #5: Audio
address: 3.0.0.0
active source: no
vendor: Unknown
osd string: Soundbar
CEC version: 1.4
power status: unknown
language: ???
currently active source: unknown (-1)

hey, I got back on my CEC quest and tried everything again: no way to get rid of that weird CEC volume issue :dizzy_face:

But! ssh commands echo volup/voldown | cec-client -s -d 1 are still working without the weird issue I thought maybe I could map my remote with special cec volume actions?

You can’t directly run that from a keymap but you can make an external python script and map to that. There is two downsides to this however. It is slow, and from what I remember when I played with this you couldn’t hold down the key to repeat. The mapping currently with an OSMC remote would look something like this…

<keymap>
<global>
<keyboard>
<volume_down>RunScript(/home/osmc/vol-minus.py)</volume_down>
<volume_up>RunScript(/home/osmc/vol-plus.py)</volume_up>
</keyboard>
</global>
</keymap>

Thanks for the quick tip!
if its going to be slow as the ssh delay yep, not very practical for volume adjusting.
Is it possible that it would be a CEC configuration issue? Having tried all my TV/AVR settings I went through different forums, and finaly came to libcec github, I don’t know if can post an “issue” there, this place looks oriented to more advanced users than I am. Anyway, I saw different commits related to volume control with libcec 5.0 label but I don’t know at all if its related to my issue… Is there a way to try libcec5.0 ?

Here are the logs if it can help

  • cec-client -l -d 1

osmc@osmc-Danforth:~$ cec-client -l -d 1
libCEC version: 4.0.4, compiled on Sun Jul 7 00:43:28 UTC 2019 by root@compiler2 on Linux 4.9.0-3-amd64 (armv7l), features: P8_USB, DRM, P8_detect, AOCEC
Found devices: 1

device: 1
com port: AOCEC
vendor id: 0000
product id: 0000
firmware version: 5
type: unknown

  • echo scan | cec-client AOCEC -s -d 1

osmc@osmc-Danforth:~$ echo scan | cec-client AOCEC -s -d 1
opening a connection to the CEC adapter…
requesting CEC bus information …
CEC bus information

device #0: TV
address: 0.0.0.0
active source: no
vendor: Sony
osd string: TV
CEC version: 1.4
power status: on
language: ???

device #1: Recorder 1
address: 3.1.0.0
active source: yes
vendor: Pulse Eight
osd string: CECTester
CEC version: 1.4
power status: on
language: eng

device #5: Audio
address: 3.0.0.0
active source: no
vendor: Samsung
osd string: Soundbar
CEC version: 1.4
power status: unknown
language: ???

currently active source: Recorder 1 (1)

I don’t see anything in libCEC 5.x that would improve things here.

I think Kodi normally just needs to see an amplifier on the CEC bus (which it does, it device type 5 in what you just posted) to switch from adjusting the signal level to sending CEC commands instead. With CEC enabled on the Vero, on the soundbar both anynet enabled, as well as the woofer button setting set to ALL‑TV REMOTE, and the TV set to whatever to have CEC and ARC enabled (no clue as the model number you provided does not produce any web search results) then I would expect it to just work. You would have to reboot after using any cec-client command though as that kills CEC from working in Kodi.

Maybe one day someone will add the ability to force the CEC volume control switch to work around issues such as this, but currently I know of no way to do this.

Actually CEC adapter volume control of soundbar is effective in kodi but the audio gets messy. Adjusting the volume mess with bass, maybe the subwoofer is forget in the process I don’t know, the weird thing is that it’s not the case with cec-client ssh commands.

Anyway it’s surely not an osmc bug and I can get around it. I appreciate your help, OSMC is awesome :wink:

I don’t understand how there would be a difference between Kodi and cec-client sending the CEC volume commands. Are you running the most recent firmware on your soundbar? When you switched over to Kodi using CEC vol control did you make sure that the volume in Kodi was set to full volume before you made that switch? This messed up sound issue is it with stereo sound as well or just surround sound sources with the issue?