Audio drop out

So I was watching my remux of The Nightmare Before Christmas with my children on Halloween night and there was this audio drop out around the 33 minute mark right before Jack says Eureeka! after opening his window.
I didn’t bother investigating it at the moment because my children could careless but afterward I was able to duplicate the issue every time.
I had noticed this before on some of my Disney UHD remuxes like Toy Story.
What I had found was that Disney likes to span the movie across multiple m2ts streams and sometimes my remuxes would have an audio drop out in a spot where streams were merged.
As an example, at the end of Toy Story 2 right before the credits roll it would have a split second drop out and if I look at the display on my Samsung HW-950 I can see that it regains the audio signal.
The display will scroll “Atmos” at the beginning of a movie and then disappear.
If I pause the movie and then unpause it, it will scroll “Atmos” again.
So when watching the movie at the end, the sound would drop, then come back as the credits roll and when I look at my soundbar I see “Atmos” scrolling.
I’ve only had this happen to me twice and both times were Disney/Pixar UHD remuxes with Atmos.
Both times I was able to fix the issue by doing a new remux.
I would put the BD folder on my SSD and redo the remux with MKVToolNix.
I have never had the issue with a non-UHD BD without Atmos.
The Nightmare Before Christmas does have TrueHD 7.1 but not Atmos.
The first thing I did was play it back from my Windows 10 PC using MPC-HC and the audio does not drop out.
Previously, with the other Disney UHD remuxes, I could duplicate the problem even on my PC so that made me confident that it was not the Vero but rather the file.
But this time I can only duplicate it on the Vero.
So I redid my remux and it still does it on the Vero only.
So I redid the remux again and included the DD 5.1 this time and the Vero plays the DD 5.1 just fine but still drops audio on the TrueHD 7.1.
No matter what I do I can’t get this audio drop out to go away on the TrueHD stream with the Vero.
So I am uploading Chapter 7 to my Google Drive and hopefully someone else can see if there Vero does the same thing or if it’s just my setup.
The audio drop will occur at about 2:41~42.
Thanks in advance for anyone willing to test this file out!

I extracted just the TrueHD stream into a file.
MKVCleaver appends the extention .truehd which Kodi doesn’t recognize so I changed it to .mka which it does.
I then played the .mka file on the Vero by selecting it in file manager and shure enough, the audio drops out at the same exact spot.
Playing that same file in MPC-HC is fine on my laptop.

UPDATE: I used eac3to to convert the TrueHD 7.1 to FLAC 7.1 and it plays back without dropping the audio.

I did get some errors in eac3to though.
Maybe someone knows what this means:

eac3to.exe tnbc.truehd tnbc.flac
TrueHD, 7.1 channels, 48kHz
Decoding with libav/ffmpeg...
Encoding FLAC with libFlac...
Creating file "tnbc.flac"...
----------------------------------[truehd @ 02582be0] Substream 1 parity check failed.
[truehd @ 02582be0] Substream 1 checksum failed.
[truehd @ 02582be0] Lossless check failed - expected c0, calculated 06.
The original audio track has a constant bit depth of 24 bits.
eac3to processing took 6 minutes, 51 seconds.

Disney often uses seamless branching to localize the movie for different languages.

The dropouts can be fixed by using a better demuxer that adjusts for the gaps or overlapping audio. eac3to does this automatically if you use it to demux. But, there are some streams where even eac3to has issues, and on those, I have found that txmuxer will solve the problem and fix the gap correctly.

Disney also often uses THD bitrates greater than 10Mbps which Kodi currently has a problem with.

Correct. We are working on a solution for this.

Very interesting.
Did anyone happen to try the Chapter 7 file on their Vero?
I don’t know what software to use to analyze the bit rate.
It would be interesting to see a bit rate analysis at that time stamp.
It doesn’t sound very busy so I doubt it’s a peak in bit rate issue, more likely a gap issue.
The only bit rate analysis I could find was this: The Nightmare Before Christmas • DE Blu-ray vs. DE 3D Blu-ray

What command in tsmuxer should I use to se if it’s a gap issue?

I tried to open my mkv up in tsmuxer and it immediately gave an error.


So I click OK and then the GUI shows all the streams except the TrueHD stream.
So even tsmuxer doesn’t like the stream.

Full logs are needed to see what’s going on.

I seem to be having a similar issue with the Big hero 6 remux, audio skips at what seems to be during the higher volume action scenes. I also get the same error as “Kontrarian” above when I open up the track with tsMuxeR.
If I turn off my audio passthrough in the Vero settings it solves the problem…

OK here are the full logs:

Thank you for providing the logs. This is a known issue with TrueHD tracks exceeding 11Mbps. We are working on a solution.


The MKV is too late…the damage is already done. You need to go to the original source disk and extract from there.

tsmuxer is complaining because the TrueHD track doesn’t have a legacy AC-3 stream.

Wait, the DD 5.1 stream is there, or did remuxing it change the stream in away that tsmuxer cant handle?
I was under the impression that DTS-HD MA has the DTS lossy core built in to it but TrueHD doesn’t and the “core” DD is just a seperate stream, is that incorrect?

That’s the log.
I enabled debug logging then did a reboot.
After boot I selected the Chapter 7 file using file manager and watched the entire file.
Searching for “The Nightmare Before Christmas Chapter 7.mkv” should take you to the relevant part of the log file.
Video playback starts at “2019-11-04 00:50:44.867 T:4045402848”.

The BluRay specification requires a fallback audio stream when advanced audio is present. For DTS-HD, it’s required to be there, as there has to be a DTS core. TrueHD does not have a core, but it can have an AC-3 stream as part of the same track, and until UHD discs were released, this is how all BluRay discs were authored.

After UHD came out, the BluRay spec changed to allow a separate track to be the fallback stream. Some BluRays use this now, but not all. Unfortunately, tsmuxer has not been updated to understand this, and requires an AC-3 stream in the same track as the TrueHD stream. Conversely, the MKV tools always separate the AC-3 stream from the TrueHD stream, and place it in a separate track.

Again, though, unless you go to the source disc and demux from there and allow the tools (either eac3to or txmuxer) to fix the gaps/overlaps, nothing can fix the audio dropouts without changing the format of the track (like converting to FLAC).

Thanks for all that information nabsltd.

Has anyone tried this file on their Vero and experienced the same drop out?