Audio dropouts every couple of minutes via NFS/LAN on RPi3

Hi,
my setup used to work great. But for at least 6 to 9 months now I have been getting random, single audio dropouts ( < 1 second) every couple of minutes when playing music. Sometimes a whole song or two go by without a dropout. However, movies run just fine for hours.

I have OSMC running on a RPi3.
It is connected to my router via LAN.
My media server is a Synology Diskstation, also connected to my router via LAN.
The Router is a (rather new) Fritz!Box.
Music and Movies are mounted via separate shares through the OSMC frontend using NFS.

Audio dropouts DO NOT occur when I share a music file from my android phone to OSMC via the YATSE remote. Same goes for YouTube videos I share via YATSE to OSMC (where I installed the YouTube Add-On).

I checked the log files a while ago. The only error logged was ‘close call failed with “NFS: Commit failed with NFS3ERR_ROFS(-30)’ pretty much for every FLAC file (I don’t have many MP3s).

What I tried:
I found a thread on boosting NFS performance and tried this line in fstab:

192.168.0.240:/volume1/music/ /home/osmc/music nfs4 nolock,rsize=16384,wsize=16384,intr,timeo=800,x-systemd.automount 0 0

It seems to mount but when navigating there in the frontend, the music directory appears empty. But my linx days are 20 years past so I don’t really know what’s going on there.

How can I help you help me?

While it is random this will not be easy to figure out but what I recommend:

  1. Can you try to play a couple of files from local USB Storage (Disk or Stick) and check if you can reproduce
  2. In your original setup with NFS suggest to enable debug logging and after you are able to reproduce share the debug logs here.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Yes, please post logs.

If your flacs are 44.1ks/s can you try setting audio output to Fixed and Max samplerate to 48k? Just as a test. Somehow I doubt it’s a network problem if videos are playing OK.

1 Like

Thanks for looking into this. I tried playing from a USB stick. No dropout for three songs.

However, reproducing the issue (over nFS) took unusually long today, more than an hour. A dropout finally occured near the end of Calexico - Algiers - (07) Maybe On Monday.flac, here’s the log:
http://paste.osmc.tv/isakiwayer

@grahamh It is currently set to “Optimized”, limited to max 48kHz. I guess before changing anything I’d better wait for a log analysis?

OK. It doesn’t sound like the issue we’ve seen on Vero but I was just curious. Maybe it is network related if local disk playback is fine.

Ok, assume it is related to the network may I suggest to use kernel mounts instead of Kodi access.

1 Like

@fzinken Thanks a lot. I changed the setup according to your suggestion and so far I had no dropouts. I would say I’ll test it for another couple of hours and then come back and confirm.

And I am positively surprised that my playlists and everything (on Yatse) still works with the new/changed library. I had expected the necessity to re-create all playlists due to the new media source. Very nice.

Have you configured path substitution?
Otherwise the database entries will use the old Methode

Otherwise the database entries will use the old Methode

Not that I know of. I scanned the newly mounted folder as a source, scanned it to the library, deleted the old source and then hit “clean database” (or some such menu item in the library settings).

By playlists I was referring to those made (and kept, to my knowledge) inside YATSE.

No more dropouts for another two hours.