Audio dropouts

I’m having audio dropouts for about a second in several movies and it is always at the same place. Checked the last movie were it happens and it is DTS-HD MA. This is only happening when I disable audio passthrough and let the Vero4k decode the audio. With passthrough enabled the audio plays fine (But my TV can only decode the core track). Should I send a log or a sample clip?

Yes, please.

OK, so here is the log file. Please ignore any potential NFS mounting errors as my NAS was off during logging. The audio dropout occurs at about 13 seconds in the clip.

https://paste.osmc.tv/oyuyenulaj

And the movie clip:

Password is: vero4k

Have you tried playing the file outside of a RAR to reduce CPU load?
CPU will be taxed significantly when decoding audio in software.

I am not playing the file from a rar archive. It is just a plain mkv-file.

Indeed. Perhaps your issue is the background extraction and scanning of RARs however, i.e.

2020-11-14 08:01:23.450 T:3733074144   DEBUG: ScanArchiveForAssociatedItems: Scanning archive /media/ESD-USB/The.Psychic.1977-(Scorpion.Releasing-aka-Sette.note.in.nero-aka-Seven.Notes.in.Black).rar

From your log there’s an audio dropout:

2020-11-14 08:01:25.919 T:3162501344   DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-28373.938654, adjusted:-28373.938654
2020-11-14 08:01:28.119 T:3462238432    INFO: CFileCache::Process - Source read didn't return any data! Hit eof(?)

because the buffer runs empty during playback

How is the drive formatted?

Use a different format than NTFS, such as exFAT.

I usually play files from my NAS with Gigabit connection, but when I did the logging I played the clip from a USB. The audio dropout happens at the exact same place whether I play from the NAS or a USB. I can play 4k bluray mkvs at over 50 GB so I don’t think throughput is a problem.

Is there a way of disabling the background scanning of rar archives? Is it a plugin?
Were you unable to reproduce the problem on your end?

I downloaded the clip and tested

  • Vero4k, buster + 4.9 kernel, HDD ext4, Sony AVR, 7.1 channel setting, with and without passthrough … no problem
  • Vero4k+, buster + 3.14 kernel, NAS nfs, 4k HP ISP monitor, 2.0 channel setting, no passthrough … no problem

So, I cannot reproduce the problem.

This time I connected the Vero4k to an Onkyo receiver and the audio dropout dissapeared. I am still not using audio passthrough, so the reciever isn’t doing the decoding.

Then I looked at the video settings and turned on “Sync playback to display” and now I don’t get the dropout when the Vero4k is directly connected to my LG C8 TV. I haven’t watched a whole movie yet, so I can’t be sure, but so far it seems it did the trick.

I wouldn’t recommend using that option. It will likely cause your video to not look smooth and you won’t be able to use passthrough with it on.

I just don’t know how else to get rid of the audio dropouts except for connecting the vero4k to the onkyo reciever or using audio passthrough and only get the lossy dts core audio instead of the lossless hd master audio (Since my TV only supports DTS core).

My recommendation is to try a demo-video, like https://www.demolandia.net/cinema/dts-demo-trailers-hd/page-3.html (which can be easily obtained by other users for comparison) to see if there are dropouts with your receiver.

I carefully re-read this thread … and wonder about your intention with the given information:

You want to down-mix a multi-channel DTS HD MA audio to a 2 channel PCM audio stream and you assume there is a significant difference between downmixing the DTS HD MA compared to the downmix of the DTS core? :man_shrugging:

Anyway, as you claim your Onkyo AVR does not show any issues using passthrough or downmixing to 2 channel PCM, the issue looks to be something special with your LG C8 TV. So, is it on the latest/greatest firmware, hdmi cable is appropriate, etc.?

Could you please retry with the following setup changes:

  • GUI -> Settings -> Player -> Video -> Adjust Display Refresh Rate (On Start/Stop)

  • GUI -> Settings -> Player -> Video -> Sync Playback to Display (Off) (really, don’t use that feature active or you accept visual micro stutters in some cases)

  • GUI -> Settings -> System -> Audio -> Keep Audio Device Active (Always)

  • GUI -> Settings -> System -> Audio -> Send Low Volume Noise (On)

If that doesn’t change anything, I’m out of ideas.

I tried these settings but unfortunately it made no difference. Having said that I have watched two whole movies with Sync Playback to Display turned on and haven’t noticed any micro stutter, and I am sensitive to that. Might be too early to tell thought. The audio dropouts did not occur in every movie and maybe it is the same with the micro stutters but so far it looks good.