Audio dropping/cutting out in movies via VERO4K/OSMC

So far it seems the reinstall solved 99% of the problem. I had some audio issue once this week, while it used to be in every movie. Weird!

Celebrated too early. Came back with a vengeance. Afraid I’m going to blow up my speakers because when the cracks/pops occur they are SUPER loud.

Honestly I’m thinking of going back to a raspberry pi instead of this vero4K -_-

I do think there’s a correlation with Dolby Digital + however.

All I can suggest is upload logs again so we can take a look.

So I put on the same movie with logging enabled that gave me so much troubles last time (lots of volume dropping and loud cracks)… and this time barely issues, but still the volume dropped out on occasion

The upload log function however is not working currently :confused:
I get the message
"Logs available at<html>"

That means your log is too big to upload. From a commandline you can grab-logs -A -T filename then find somewhere to upload the log file that’sproduced.

Ah I see, good to know, thanks.

  1. big file from a full movie: Deleted

  2. I just had a file where it was happening all the time again, so I made a really short logging as well where it happened once.

  3. I also noticed some lights on my receiver go out when it happens:
    Quick Share
    the lights basically correspond to my speakers. (LFE LR FR C SR SL - the C is weird since center is disabled though)

do you think Majority of DD+ passtrough audio broken on Vero4k with Pioneer since 1.5 Years - #16 by Thierr might be related? The test files he uploaded worked fine for me however.

There’s a load of logspam there from the upnext addon. If you disable that, do things get better?

Still the same. And it really only occurs on DD+ files.

Is it possible that there is simply a hardware problem with the vero4K?

Extremely unlikely, particularly if nothing else is problematic. I think the fact it also works on the LG TV okay rules out an issue with the Vero.

I’ll make a recommendation after the next update.

Hey sam, thanks for the reply.

I think the fact it also works on the LG TV okay rules out an issue with the Vero.

I think you misunderstood. I meant that when I play content directly from my LG tv (eg through its own file browser) it works correctly. It’s not that the vero works correctly on another TV (i dont have any other to try out)

Okay, thanks for clarifying that. I did indeed misinterpret.

Issue persists, but only with DD+ files. For now I simply stopped using my vero4K since most of my files are DD+ :-/

A full reinstall of osmc did not help.

Hi there,
i have problems with audio files, too. When reading an mkv file with DD+ audio 6.1, i simply can hear cracks and drops ONLY, listening the stream is not possible.
I have to set the audio settings to channels 2.0 and active the transcode function to have the audio working.
It doesn’t matter if i use my projectors integrated loudspeaker (HDMI) or my AV receiver via TOSLINK.

The other problem i have is when using LiveTV via my tvheadend server. The channels with AC3 5.1 sound are cracking when using passthrough. Transcoding solves the issue, but i don’t know why a simple passthrough is not working…

Just my 2 cents, i can upload a test logfile if needed.

You should start a new post with logs and details of your setup to get proper support, but from what you posted it sounds like your equipment doesn’t support DD+ and more than two PCM channels. Enabling transcoding to AC3 is often what must be done to play newer sound formats on equipment lacking certain features. There is a good audio configuration guide over on our wiki that may be of some help.

1 Like

Is there anything I can do? Clean install didn’t help, I posted logs quite a few times. It only occurs with DD+ files, and renders my Vero4K+ unusable :frowning:

Did you try disabling DD+ plus passthrough and enabling AC3 transcoding as previously suggested? This would also require setting channels to 2.0.

Did you try to connect the Vero directly to your AVR via optical instead of using ARC as previously suggested?

Disabling DD+ solves it, yes. But ofcourse that’s not an option.

I don’t have a toslink cable. I could buy one to try it out, but how does it work? Would it still allow audio passthrough?

An optical cable has the same capabilities as the ARC you are using now. It sounds like the issue is that your TV and/or AVR is not correctly passing DD+ from an external source via ARC. If having the Vero convert DD+ to DD is not an option, then buying a TosLINK cable would likely be the cheapest option to overcome this. This is assuming your AVR has an optical input.

Optical can’t carry DD+. Although given a typical DD+ bitrate of around 768kb/s a conversion to DD will irw sound identical.

Optical can carry DD+ but it is not supported by the spec. If you change Kodi’s passthrough output device to S/PDIF you will no longer have the option to passthrough DD+ as well which is which is according to spec. That being said if you leave the passthrough output device as HDMI and set passthrough for DD+ it will be output via the optical port on the Vero. With this being out of spec there is no assurance that an AVR will decode it, but for the cost of a cable IMO it is worth a try. I just tested it on a Vero 4K and a Denon AVR and it worked without issue that I could see or hear. I even unplugged the HDMI cable from the Vero just to be completely sure the audio was traveling over the optical cable.

The better method of dealing with an older AVR without replacement is to use a HDMI splitter to send the audio and video to the TV and AVR separately, but that is going to be pricy compared to just an optical cable.