Audio issue with x265 video files

Since the latest software update on my newly purchased Vero 4k player, I am having major issues when I am playing a video file that is encoded in x265, the music aspect of the file plays normally however the dialogue sounds like it is playing in the back of a large concert hall (it is extremely quiet and echoes, and the dialogue can only be heard if there is no music playing in the background of the file).
This issue does not happen with any other type of video files, any help?

It’s possible these files are encoded differently (in terms of audio track) to your other files.

Can you describe your audio setup? Do you have an AVR?
Can you take some screenshots of your audio settings via Settings -> Audio? Usually this needs a minor bit of setup for the best experience.

I will send pics of the audio setup, but to clarify, the files that play with no issue are encoded differently thus it only happens on x265 encoded files. But more importantly, this wasn’t an issue at all, everything played fine when I purchased the box a month or so ago, it has only happened since the software auto update about a week ago. Photos to follow.

We haven’t released a software update in the last week. But there have been some audio changes.

It’s possible you’ve only recently updated to a newer version of OSMC which fixes a multi-channel layout audio mapping bug. The result of this is those that had misconfigured / or not configured their audio experienced problems. For other scenarios, it’s a marked improvement. If that’s the case, it would be an easy fix once we know more about your audio setup and see the screenshots.

Sam

Don’t know why one of the pictures uploaded upside down, sorry about that… In answer to your earlier question, yes to an AVR.

Try enabling Expert Settings (on the side) and enabling passthrough for formats your AVR supports.

A debug log will let us see what’s unique about these x265 files and why you might be experiencing issues.

Expert settings already enabled, changed to DSP processing as indicated in this photo but unable to open the highlighted manager sub menu

Do not enable DSP processing. It’s broken in Kodi v17 and may give you crashes.
Doing so disables passthrough I believe, which is why the passthrough section is blank.

Sam

Set your Number of Channels to 2.0, then passthrough should show up.

This isn’t a pre-requisite.
You only want 2.0 + passthrough if using SPDIF (Optical)

I have disabled it but the passthrough section is still blank and it jumps over the section entirely when scrolling up and down on the remote. This still happens when I change the output to 2.0 from 5.1
From memory, before whatever updated this section was open and I had DTS etc enabled

If you set your channels to ‘Fixed’, you lose passthrough.
Set it back to ‘Optimized’ (default)

Changed to optimised and 2.0 output, passthrough section has opened up and the video files now play perfectly. Thank you!

:+1:

Glad to hear this.