Audio over HDMI broken after recent update

So I updated my Rpi2 a few nights ago to the most recent version of OSMC and for the last few days everything was working fine. I ran sudo apt-get update last night to update all of the other software. Everything ran fine last night after a few reboots and I was watching the news on it with no problems while having my morning coffee this morning.

I get home from work (pi has been ‘shut down’ since around 8:45am) and when i boot it up no program has audio (not googlemusic or even a video file). I run my rpi2 over hdmi onto my panasonic LCD tv and i’ve had no issues with audio for the month or so i’ve had this setup. I do notice audio DOES work over the line-in jack. I have tried switching the hdmi cable and switching inputs. I have confirmed that the both of the cables i’ve tried do work.

I added the following to my config.txt
hdmi_force_hotplug=1
hdmi_group=1
config_hdmi_boost=4
hdmi_drive=2

still nothing. No quiet audio, no nothing. Here is the info on my device:
Device: Rasp Pi 2
Installation media: Micro SD Card
Connection: Wifi
Power Supply Type: 5v (ordered online specifically for my pi)
Peripherals: xbox 360 wireless controller dongle, wifi adapter, logitech wireless kb adapter
OSMC version: 2015.08-1
Audio/Video Output: HDMI
Overclocked: YES to 970, but i have tried it with all settings set to default
Config.txt Extras:
hdmi_force_hotplug=1
hdmi_group=1
config_hdmi_boost=4
hdmi_drive=2

i’m lost as to where to start as I can’t think of anything that could have randomly triggered the issue.

I would remove the extraneous lines you added to config.txt, shutdown your pi, unplug the TV’s power from the wall momentarily. When the TV has fully booted again and is set to the correct input for the Pi, restart the Pi. If the behavior persists, provide the output of these commands.

tvservice -s | paste-log
tvservice -m CEA | paste-log
tvservice -m DMT | paste-log

Well i did not expect that to solve the problem… but it did! Thank you so much!

Can you explain any idea how or why that happened and how rebooting the tv and pi in such a way could correct it?
Just curious. I’m trying my best to understand everything i’m doing with this thing and why it reacts the way it does in certain situations. THANKS!

The pi sets it’s output based on data that the TV provides. This is true for video resolution as well as audio capability. This doesn’t work if the TV or pi gets “confused” on how to do this. Read about edid.dat provided by your TV here http://elinux.org/RPiconfig#Which_values_are_valid_for_my_monitor.3F

1 Like

See: http://kodi.wiki/view/Raspberry_Pi_FAQ#TV_is_not_detected_unless_powered_on_first