Audio passthrough issue on HD bitstream

Just started using the vero4k and getting my head around it.
I bought it to be able to natively play back my UHD rips and it seems OK (I do appear to have some network buffering problems, but that’s another story).

I’ve tried two different MKV files, both with h265 video and DTSHD-MA audio sountrack.

However, it seems impossible to get any audio bitstream out via HDMI.

I have set up the Vero4k to allow passthrough, ensuring all the audio codecs are ticked (DD, DTA, HD codecs, etc). But it always appears to be decoding and sending 7.1 LPCM to my processor.

I can grab screenshots and logs when back home, but wondered if I’m missing anything obvious.

Make sure Sync Playback to Display is not enabled.
Otherwise, a debug log will be helpful.

Thanks @sam_nazarko
I’ve checked that Sync Playback to Display is not checked.
I’ve tried with a few MKV files now and it’s always a 7.1 LPCM fed to my processor and not the DTSHD-MA audio.

I’ll look at getting a debug log. Anything in particular on how best to get what you need? I’ve logged into the Vero via SSH.

Thanks for your prompt response and apologies for my time to reply. :slight_smile:

Strange. It’s now working :slight_smile:

It could be that I hadn’t restarted since ensuring the Sync Playback to Display is not checked.

However, does that now mean I need to manually set the display refresh rate and the Vero will no longer output at the same rate as the source material?

With that setting on, the Vero will set the video rate to match the display. With it off, then the display refresh rate will be set to match the video.

@xavier1 Please provide some more data

  1. in the GUI go to settings -> system -> logging (if you don’t see it, change to expert mode at the left bottom)
  2. activate logging and all flags
  3. reboot the box (main GUI -> power menu)
  4. now reproduce the issue playing a DTS-HD MA video which will be received as LPCM
  5. login via SSH
  6. grab-logs -A and provide the presented URL here