Audio Playback - RP3 Problems

Hello,

I got a RP3 and im kinda extremly disappointed with it. Got the latest OSMC and have rebooted twice and are wired connected.

I was trying to watch a 1080P video with DTS track on it with passthrue but i got video and audio problems.
Started with the audio of the movie to dissapear every 1 min then cames back after some seconds.
Switching to oassthrue of and the error is still there.

I recorded a video of it so you can see and hear for yourself.
Even the video is problem with movies that have DTS tracks in it.
No problem with the video, tv, AVR or cables. same stuff to a HTPC works just fine and even better and with DTS HD-MA

Advice is most welcome.

Video Link

Thanks
HA4g3n

While the video you’ve provided does a good job of showing us the symptoms, debug enabled logs obtained while demonstrating the issue would be more helpful.
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Does every video file behave this way?

Ohh sorry.

Well after testing every video does this now so i guess i have to reinstall OSMC completely.

I tried to edit the log and save but got write error: [ Error writing /boot/up.txt: Permission denied ]

Logged in as osmc/osmc in a ssh session.
Maybe currupted SD card?

Hello again,

Here is the log while playing first a 1080P movie with DTS track (BaB) and a then another movie with ac3 audio.

Same error on both like in the video.
Im very suspicious about my SD card and thinking about reinstalling and i must admit i have dualboot with Noobs and that might not be recommended by OSMC?

thanks in advance.
HA4g3n

Hi again!

I just formated my card and reinstalled the OSMC and updated to the latest.
Same error.

Screen sometimes get pink and screen is blinking like it losts connection.
So i played around withthe video settings and after lowering the resolution everything is working now.
Is there any settings to lower the bandwith on the HDMI cec maybe? Since it´s working on the HTPC with DTS HD-MA that user a higher amount of bandwith or what do yuo think it could be?

Thanks

You should try adding config_hdmi_boost=7 to /boot/config.txt and see if it improves your symptoms. If 7 isn’t helpful, you can try up to 11.

From http://elinux.org/RPiconfig#Video -

config_hdmi_boost configure the signal strength of the HDMI interface. Default is 2 on Pi 1 model B and 5 on later boards. Try increasing if you have interference issues with hdmi (e.g. to 7) 11 is the maximum.

thanks,

I tried both value 11 and 7,
7 = picture is now better no flickering and no pink screen but audio is now worse.
11 = the picture is worse and audio does not exist at all.

Rebooted after config was written every time.
Wrote reboot in cli and the machine was not answering so had to reinstall again…

Is it an excessively long HDMI cable? Did you test with another? What power supply are you using.

Well, yeah its around 10m long.
But it´s working from the HTPC so it´s kinda wierd it does not work on RP3.
Edit, im useing the more powerfull 2.x ampere powersupply recommended by RP3.

This is an apples to oranges comparison. I would test with a shorter cable.