Audio problem wHifiBerry DAC sound card on Pi4 and Osmc

I installed on my Pi4 a wHifiBerry DAC sound card following the following instructions AUDIO+ installation guide - Installation guides - Raspiaudio.

With the TV turned On the audio can only be heard with vc4-Hdmi settings with the TV turned off however it also works configured as snd_rpi_ hifiberry_dac.

I don’t understand what causes it…

some idea?

Have you tried contacting the seller / manufacturer for advice?

Hard to advise without logs

As Sam says, the HiFiBerry people would be the ones to ask. OSMC uses ALSA just like any other Linux on Pi. The instructions for OSMC on their site look OK but a bit old.

If you post logs with a timeline of what you are doing (when you plugged/unplugged the TV) that would help.

Thanks everyone for the replies.

I tried to contact the seller but he sent me back to the link I indicated in the initial post.

I’m definitely doing something wrong that escapes me at the moment.

Currently, to be able to hear audio on the PI setting of the sound card I have to set the Soundcard Overall item to none and not select the hiFiBerry-dac sound card.

As per the image below:

else if I do as indicated by the official guide I don’t hear any sound on TV On I only hear it when the TV is off

in audio settings I have the following entries

vc4-hdmi, MAI PCM i2s-hifi-0 and vc4-hdmi, SAM SAMSUNG on HDMI
they are present only if set PI setting of the sound card I have to set the Soundcard Overall item to none and they allow me to hear audio output from both HDMI and soundcard.

So you can get audio from the card?
But you want to mute HDMI?

Hi, I carried out further investigations and discovered that if I disconnect the optical connection that goes from the TV to the amplifier the audio can be heard correctly.
In my configuration the TV is connected with an HDMI cable to the Raspberry and with an optical cable to the audio amplifier (to hear the TV audio on the amplifier when I am not using the Raspberry).

On the Raspberry the sound card output is connected to the amplifier (to hear audio on the amplifier) ​​.

Now when I use Kodi the audio comes out both from the TV and from the Raspberry sound card and I have to lower the TV audio to 0 so as not to hear the sound from both the TV speakers and the amplifier.

Now I noticed that when I launch retropie to hear the sound with TV turned on I have to disconnect the optical cable.

Is there no way to configure Osmc so that it behaves like Kodi by playing audio from both the TV and the Audio card?

I’m confused. Are you saying you do or don’t want dual audio output?

Sorry I made a mistake, I meant I would like Retropie to behave like Kodi.

Alternatively I would like to understand if it is possible to disable the TV’s optical output from OSMC

I’ve never seen or heard of any display that has options for a connected device to change its toslink options. Typically in a situation like this where there is an older amplifier being used one would just connect the RPi to the TV via HDMI and the TV to the amplifier via optical and change the TV’s settings to mute internal speakers and output via the optical.

Thanks for the reply. I have already disabled the speaker output on the TV and enabled only optical output.
The problem is that when I run RetroPie to hear audio I have to disconnect the optical cable from the TV to hear it from the sound card’s audio output and I don’t understand why.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot: