Audio problem with a Movie

Hi All,

I have an audio problem with a Movie. This Movie worked fine in the past, today evening I started it for my kids and suddenly the audio didn’t worked any more. I tried to play with Audio settings but there was nothing I can do. Consider that this summer I used Kodi very few time and all movies worked fine. I tried to do the update of OSMC but it don’t work.

Using mediainfo on the file I found the following feaures for my audio file:

ID : 1
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Codec ID : 2000
Duration : 1h 32mn
Bit rate mode : Constant
Bit rate : 448 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 295 MiB (26%)
Alignment : Aligned on interleaves
Interleave, duration : 83 ms (2.00 video frames)
Interleave, preload duration : 192 ms
Title : ITA AC3 5.1 448 kbps

To be honest I do not know where to start my debug. Which log can I check? Is there any know issue? Any setting I can check?
Thanks in advance for your help.

This files it’s stored ? on attached usb device ? You play it from a network place sharing ?

On PC this files it’s works ?

As usual enable debug logging and then the kodi.log is your friend to find out whats wrong.
Considering this is a AC-3 file the main question is how is your Audio setup? Are you using passthru or is the Pi decoding this for you?


The problem was a simple audio setting I changed in Settings->System->Audio disabling Allow passthrough. I have also “Enable audio DSP processing” disabled.