Audio stuttering on OSMC Kodi Vero 4K+

I have an issue with audio playback. On some movies/tv series with dramatic music (now Umbrella Academy on Netflix), sound is stuttering. It did to me before but I solved it by changing Widevine version. Now I changed Widevine through SlyGuy plugin back to 4.10.2252.5 with no change (I also tried 4.10.2252.0). I tried to change the resolution from 720p to 1080p and even to 576p but with no luck/ no change. Same issue is with HBO (Game of Thrones). Few months ago it worked fine.

I asked at Netflix Github forum and author wrote that is is not plug-in problem, but Kodi problem.
Example of problem:
Log file:

You said that it worked a few months ago. Are you using the same Widevine version as a few months ago? Widevine updates are known to cause regressions… particularly with performance.

I used 4.10.2252.5 as stable version, after upgrade to new version I tried to go back to stable but with no luck. Funny that picture is not stuttering.

Perhaps some others can chime in and try and reproduce the issue with the two shows / services you have mentioned. I can look at this at a later date.

Is there somewhere in those logs where you actually played one of these files that are not working correctly? I wasn’t spotting it.

On a completely unrelated note you have an issue with your advancedsettings.xml file.

This section is wrong…

<!-- <disablehttp2>true</disablehttp2>stutter problems on livestreams -->

This should be…

<!-- <disablehttp2>true</disablehttp2>stutter problems on livestreams -->

Although at present it doesn’t actually make any difference as it is just ignoring those cache settings which happen to already be set at those exact settings in OSMC by default. If you wanted to play with different settings though you would need to update your tags to the current Kodi naming scheme.

Thanks, I changed it in advancedsetting.xml.

I made fresh log of problem - ending screensaver and playing problematic part:

Ok, now my kids tried to play movie from local drive (NAS) and problem is also there. It is similar the problem, when I used different resolution than FullHD 1920x1080.

Ok, so last attempt was to install Test version. But it failed to install (unknown component).
So I got back to update system from terminal. And after
sudo apt --fix-broken install
i got:
dpkg: warning: ‘ldconfig’ not found in PATH or not executable
dpkg: error: 1 expected program not found in PATH or not executable
Note: root’s PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin

Apparently ldconfig is missing so I think best solution is to backup config and fresh install. Am I wrong?

I would suggest a fresh install using an image from that test thread.

So result so far: I had to use Etcher - osmc installer on Mac OS 12.4 is not usable.
It took me almost a day to get back to usable version of Kodi (at first addons crashed a lot).
I finaly tried to play local file after restoring setting - and it sutter again. It’s even worse than before.
I made short file _zvuk.mp4 and this is log:
I can even upload the file.

I would suggest uploading a test file


I owe you a big apology. I finally found out the problem. It was not in the Kodi itself, it was the amplifier. Even though the symptoms was same as I mentioned in the first place (wrong resolution), now the problem are speakers with integrated amplifier.

I’m very sorry that I wasted your time.

Glad to hear this. I could not reproduce the issue, but did flag this post for follow up when I had a bit more time