Audio Suddenly Glitchy

I’ve had my vero4k for months and suddenly in the last 2 days the audio has become glitchy. The glitching occurs when there’s sudden high pitch/frequency audio (e.g. the bleep sound when swearing is censored). Also sustained high pitch audio (e.g. piano music) sounds warbly or underwater.
The vero 4K is connected to my TV via HDMI and the TV is connected to a sound system via optical. I have a PS4 setup in the same way and there’s no audio problems with that…

Edit: I also reconnected my RPi3 in place of the vero and it has no audio problems…

…so it seems to be isolated to the vero.

The glitching doesn’t just occur during playback; it happens with some of the gui sounds too. I’ve tried changing various audio settings but it hasn’t helped. I’ve checked all the cables, unplugged and replugged everything, restarted etc. Any advice would be appreciated.

Could you please post debug logs after playing an affected track. Is it all types of media affected? If not, which types?

Screenshot of audio settings would also be good

Sam

@ grahamh

Here’s the logs https://paste.osmc.tv/nihunajine.

Is it all types of media affected?

As far as I can tell… yes. I’ve played mkv, mp3, mp4, avi, youtube videos and as I mentioned before the gui sounds (I’m using Aeon MQ 6 UI Sounds). With more consistent audio like with music and video, I can hear it wavering like it’s underwater. Most of the time it’s subtle but, when the audio becomes higher pitched or when it contains higher pitch sounds, I can hear it glitching/crackling too.

@ sam_nazarko

I don’t know of a way to screenshot all settings at once so I assembled a few screenshots:

Please note, once the glitching started and I started trying to fix, I’ve changed all the settings and now I can’t recall exactly which ones I started with. As far as I can tell, I’ve tried every different config available and the only difference I heard between them was when I switched from PulseAudio to AML-M8AUDIO, HDMI and then it got so bad I had to mute the audio until I changed it back. The point is these may not be the recommended settings anymore but it was working fine for months with whatever settings I had… until it started glitching anyway.

EDIT I just noticed the image is missing the Enable Audio DSP settings… it’s not enabled.

AFAIK, Vero4k doesn’t use pulse unless you have the a2dp app, which you don’t. Do you have a custom setup for audio?

AFAIK, Vero4k doesn’t use pulse

Hmm. The only options I have for audio output device are:

  1. Playback/recording through the PulseAudio sound server
  2. PulseAudio Sound Server
  3. AML-M8AUDIO, HDMI
    I’ve tried all 3 while trying to fix the audio problem. There doesn’t seem to be any difference between the 1st & 2nd options. As I mentioned before AML-M8AUDIO, HDMI causes all sounds to come out as very scratchy and garbled high-pitched tones.

So, considering 2 of my 3 audio output options are to do with pulseaudio and the 3rd causes nasty shrieking), the questions I now have are:

  1. why do I have pulseaudio?
    and
  2. what audio output options should I have?

[15mins later]

Okay I looked through my apt history.log and found that I’d installed pulseaudio when I was trying to add some more visualisations. I guess the instructions I was following included installing pulseaudio for some reason.

I didn’t make the connection between audio problems and visualisations being installed especially because I installed that 3 weeks ago and the problems began about 1 week ago.

I then tried looking for what the default audio output options would be if I hadn’t installed pulseaudio and found a post by someone else with different audio problems and where sam_nazarko had replied to the post saying the guy should try removing pulseaudio and reboot. So I figured I’d try doing the same even though the audio problem was different.

After reboot the audio output options I had were:

  1. AML-M8AUDIO, PCM
  2. AML-M8AUDIO, HDMI

PCM had been selected automatically but I tried switching to HDMI again to see if it was still going screech at me. So far, so good - no screeching.

But, more importantly, the audio problems (glitching and underwater effect) seem to have been fixed.

So, thanks for your replies, they got me looking in the right direction. Appreciate it.

Cheers

Glad you got it fixed, and an interesting case. I understand pulse and Debian Stretch aren’t happy together anyway so anyone using a visualiser that uses pulse could have issues.