AudioProfiles dont work anymorce since 19.1 update


switching the profiles of the addon AudioProfiles dont work anymore since the osmc update to 2021.08.01 / 19.1.

I have updated the addon AudioProfiles also to the current version 2.1.0+matrix.1.

Here my keymap configuration:

osmc@osmc:~/.kodi/userdata/keymaps$ ll
total 24
drwxr-xr-x  2 osmc osmc 4096 Sep 17 11:30 .
drwxr-xr-x 10 osmc osmc 4096 Sep 16 16:54 ..
-rw-r--r--  1 osmc osmc  367 Sep 17 10:42 audioprofiles.xml
-rw-r--r--  1 osmc osmc  162 Aug 10  2020 audio_sub.xml
-rw-r--r--  1 osmc osmc  241 Aug 10  2020 codecinfo.xml
-rw-r--r--  1 osmc osmc 2164 Jul 14  2020 sms.xml
osmc@osmc:~/.kodi/userdata/keymaps$ cat audioprofiles.xml
#keyid red    61584
#keyid green  61585
#keyid yellow 61586
#keyid blue   61587

The button F1 (key id 61584) and F2 (key id 61585) dont switch the profiles anymore. This worked until the update fine.

Can you help me why this now no longer works?

  1. You might have to update the Audio Sink Config in there as that has changed with the latest update
  2. If you want help provide debug enabled logs

hello fzinken,

here my log: hastebin

What are the two Audio Profiles you want to switch between?

Profile 1+2

i have fixed it… :slight_smile: the #-lines have caused a problem

osmc@osmc:~/.kodi/userdata/keymaps$ cat audioprofiles.xml

works fine now!

Overlooked those, surely that # cases a syntax error in the line

all fine… thank you!