August release -> Bluetooth issues with Logitech Elite remote

Hi, really enjoying the Augusts release. Great to have 3D MVC support out of the box! Thank you.

I had some issues with SMB named shares, but have change to IP and everything works fine.

Expect one thing, my Logitech Elite remote is having issues with the Bluetooth connection which fails after some time. I also can’t make a connection with PIN. The Vero4K is failing to make a connection with this option. Without PIN it works, but fails after a couple of hours. I have to delete the connection and make a new one to get it working again.

Is this a known issue, or do you need log files?
Not sure if you can see this error in log files? If you go to the Bluetooth screen, the icon is red in stead of green.

Strange is:
I am using two Vero 4Ks, both with Logitech remote on Bluetooth.
I have upgrades one which works fine, but the one on which I did a clean install fails after some time.

1 Like

Someone reported issues and said that rebooting their Logitech hub solved the problem, so you could try doing that.


Hi Sam,
Thank you for responding. I do understand it is busy times at this moment during after care.

I already did reboot the hub several times and made reconnections from scratch, but it keeps popping up. Unfortunately I can’t test at this moment because I am awaiting a new beamer… so if you need a log it can take a few days. Sorry.

Hi Sam,
Sorry it took a while before I was able to use the Vero again because delivery of the new beamer was delayed and because of a 3 week holiday :-).

This week I have been using the Vero again and I am still having issues with the Logitech Elite disconnecting. I also am not able to connect with PIN which was working with 18.9.

I have made a log while connecting with a PIN, which fails, and with connecting without a PIN. Which works for some time, but very unpredictable when it fails. So hard to get a log when it happens.

If it fails only way to solve the issue is to remove the Bluetooth connection at the Vero and reconnect without a PIN and use it till it fails again. Almost on a daily basis unfortunately.

Log file:

Hope you can find the issue with this log?

I don’t see anything.

Did the hub get an update recently?

Hi Sam, not that I am aware off.
The Vero which is having issues has been installed from image / scratch. I have another Vero which has been upgraded. Both are using a hub, but only the one which I installed from scratch is having issues.

So that’s a bit strange. I can keep on running the Vero till it fails with logging enabled, but it will take some time and the log will be big. I can also install the Vero from image another time. Which do you prefer?

Regards, Olaf.

Try the November 2020 release.
This will help rule out a regression.


I will, but My OSMC doesn’t find an update to November release at this moment.
Can I update in another way? Or do I need to install from image which will reset the Vero?

Can’t find the image either at this moment for the Vero. So I assume it will be released soon?
Will update with My OSMC as soon as you release the update.

Oh sorry. I missed the 2020. So you want me to try the 18.9 release :-). I will do so.

Hi Sam,
Installed 18.9 image and can connect to the hub with PIN again. So I assume the issue is solved. Did not do any other configuration and will update to latest release to test if the Bluetooth connection to the hub is stable this way. Will keep you posted. So it looks like we have some kind of regression because with 19.1 release I am not able to connect to the hub with PIN.

Hi San, somehow you do have a regression impact from 18.9 to 19.1 release.
Since I have connected the hub with 18.9, updated the release to 19.1, everything is working fine. But if I do a clean install with 19.1, I can’t use the PIN connection to the hub and the connection isn’t stable.

For me the issues is solved at this moment, but question is why doesn’t this work with a clean install on 19.1?

Thank you for your support!

Bluetooth shouldn’t have changed significantly in the new kernel.
If this occurs again, can you leave it in a broken state so that we can perform some more troubleshooting steps?

Yes of course, but at this moment everything is working fine since update from 18.9 instead of clean install with 19.1