August update and Wifi channels above 100 not working

First of all thank you for the update :slight_smile:

I was a little reluctant to take the step and update to Kodi v19, but I hit the button and almost everything went fine, except that that after the update, I could not connect to my WIFI, Changed my AP wifi channel from 112 to 48 and then I could connect.

The Vero can’t even see the AP if the channels are set to 100 or above that.

Made a little test, and everything up channel 64 is working but from 100 and up is not working.
Bandwidth is set to 80Mhz

Is channels above 100 not supported in this update? Had it on channel 112 before i made the update, with no problem.

A bit of a long shot, but have you installed and configured the CRDA package? (You set the country code in /etc/default/crda.)

1 Like


No not installed the CRDA package. Is this required for the upper channels to work? it did work with Kodiv18

It might be a kernel-related issue, rather than Kodi-related. Worth a try.

Hi Thomas,

It’s interesting that CRDA needs to be used and set.

We are looking at the possibility of allowing WiFi region to be set in My OSMC → Networking, but I had thought I had bodged a fix for the 4.9 kernel.

Were things OK on the previous version?

Some logs would be useful.

Ah, that would explain I couldn’t connect to my 5Ghz AP as it was on 100, the Vero could only see my 2.4Ghz AP as that was on a lower channel. It worked fine in the previous version.

Here’s a log, I rebooted and navigated to the wireless page under My OSMC

Thank you for the logs, as I am not able to upload logs at the moment.

From your logs it seems to me that it is a regional setting problem, as the country code is set to China, and from what I understand based on this link Wlan channels permitted, only these channels (36, 40, 44, 48, 52, 56, 60, 64) on 5Ghz are permitted in China.

Aug 09 13:30:13 osmc kernel: dhd_conf_set_country: set country CN, revision 38
Aug 09 13:30:13 osmc kernel: CFG80211-ERROR) wl_cfg80211_event : Event handler is not created
Aug 09 13:30:13 osmc kernel: Country code: CN (CN/38)

1 Like

Thanks, where is that set? I can see the Regional page in Settings/Interface but they’re all set correctly to English/UK.

I have no idea :slight_smile: I am not even sure that is the problem, just guessing from what I can see in the logs.
But i am sure that @sam_nazarko and his team can fix this problem :slight_smile:

No, you would need to install crda and set via /etc/default/crda

sudo apt-get update
sudo apt-get install crda

then sudo nano /etc/default/crda


I have already tried that, but I am not 100% certain on what the REGDOMAIN= should say.
I have tried the three following with reboots after edits without success.


If you want to avoid reboots your first can try to set it with iw like

sudo iw reg get
sudo iw reg set DK

Or maybe try Europe sudo iw reg set EU

REGDOMAIN=GB worked for me, thanks!

1 Like

Just a little update, tried both GB and EU, and they work, but as soon I set to DK it disconnects.

I just keep it at EU. Thank you @fzinken for your patience :smiley:

Does it work after a reboot? Mine fails to connect after a reboot.

Yeah, it works after a reboot.

I was having a few issues with the connection though, playback was stuttering. On the wifi page I clicked the Apply button and waited until the status said ‘Connected’ and that seemed to fix it.

AFAICT, CRDA uses a regulatory table at /lib/crda/regulatory.bin, This is in binary format but can be dumped using the command regdbdump /lib/crda/regulatory.bin | more

From personal experience, setting the regdomain using iw reg set XX doesn’t survive a reboot, though I know that @fzinken has had some success with that command. We never figured out why our experiences differered.

1 Like

I also put REGDOMAIN=GB in /etc/default/crda and the channels survived a re-boot.

1 Like


Only had this occur today, as I patched and rebooted my AP and its channel’s set to auto.

But REGDOMAIN=GB in /etc/default/crda doesn’t to be working for me on one of vero4ks.
I still need to run

sudo iw reg get
sudo iw reg set GB

These only work if Regdomain, hasn’t been set.

For my wireless network to be visible. Currently I’ve unmasked rc.local service and added:

iw reg get
iw reg set GB
connmanctl connect wifi_442c059d9a74_446f796c6535_managed_psk

Then restarting kodi, once the wifi is up. A search of the forum would indicate that adding country code here may help:


I guessed I may need to change ccode=ALL to ccode=GB, but this didn’t seem to help. Is that the correct change?

Thanks Tom.