Auto-mount Issues with External USB HDD

For years my external WD drive was mounted automatically in /media/WD/. A few weeks back it stopped. Turns out the USB drive is being mounted when plugged-in while the Pi is running but not when already plugged-in during reboot.

Tried a few other USB drives, same issue.

Has someone an idea how to fix this issue?

Just some ideas:

  • Aged or wrong power supply to the Pi?
  • Already tried with a self-powered USB hub between the Pi and HDDs?

Also some logs could help to help you:
To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.