Auto Refresh Rate

I’m a total newbie with all this ,so can anyone help , Ive just bought the vero 4K+ and I’m putting it through my Denon AVR and then to my LG C8 oled , my problem is, when I select the auto refresh rate option in the kodi media player and then start a movie or video file I lose the picture signal and have to reboot the vero , and if I turn off the auto refresh rate the movie plays fine ,

Without auto refresh rate, the movie will play at the GUI resolution. For various reasons, we recommend setting the GUI (settings->system->display) to 1080p60Hz.

For LG oleds, many people have found setting 422 in settings->system->display helps.

Can you go to My OSMC -> Logs and upload a full set of logs (with debugging enabled) if the issue persists after making @grahamh’s suggested changes?

does that mean if I play a 4k movie it will only play in 1080p

It will play in 4K if the file is 4K.

so whats the advantage of the auto refresh rate because I`ll be mainly playing 4k files

It’s not recommended to run the GUI at 4K.

Adjust Refresh Rate will change the refresh rate to match the content you are playing. Without it enabled, content may not look as smooth.

but as soon as I enable the refresh rate, and try to play a video file it loses the video signal and I have to reboot the vero

Do you really have to reboot? Doesn’t pressing Stop take you back to the GUI?

no , I get no signal on my TV and when I press stop( or any button on the remote) nothing happens and have pull the power cord out and then it starts up to the main menu

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I’m afraid you will have to use ssh to get the logs when you have no picture.

Out of interest, what happens if you connect Vero direct to the TV?

I used the HDMI cable supplied by yourself which i think was faulty but I have now changed the HDMI cable to another one which has seemed to work.

1 Like