Auto resolution switch between 1080p and 1024x768 - Possible?

I triead searching but didn’t found a clue. I have a Vero+ linked to a 1080p projector (and hifi, via optical).
I’d like to use the Vero to listen to music, but the projector as display is overkill. I have an old 1024x768 LCD. I attached it but it didn’t work unless I manually changed the resolution.
Is there a setting on the Vero to change automatically the resolution based on the attached display?

To be clear: I have the Vero--------->HDMI switch----->VGA adapter------>old LCD
on the other port of the switch there is ------------------> 1080 projector


This will happen automatically – there is code to detect HPD events. Make sure HPD Lock is not enabled under Settings -> Display.

My HDMI->VGA adapter doesn’t pass through the EDID from a VGA display but uses a generic one.

What resolutions are you able to use with the LCD screen?

If you leave the UI resolution at 1024x768 and enable adjust display refresh rate to “on start/stop” then that display should work fine for playing music and playing videos on the projector will switch to the higher resolution. The downside would be that the UI is going to be lower resolution and 4:3 aspect on the projector.

Thanks everyone, I’ll try as soon as I get home

No luck, the HPD lock was already disabled, still the LCD says “out of range”. I checked the whitelisted resolutions, I don’t see resolutions like 1024. Maybe should I add it manually? How? Is there some config to edit?

So you did get it to work or not?

No, It doesn’t auto change the resolution. Maybe should I manually add 1024 to the White list?

Can you post a log so we can see what is being reported.

How to post a log

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

ok, I’ll do as soon as I can

Vero will only send resolutions that are advertised by the display. It’s not possible to add resolutions to the whitelist that are not advertised. Logs will show us what those are. Please connect the LCD screen and reboot before grabbing the logs.

Hello, sorry for the wait:

(I started up using the HDMI, then attached the vga, then again HDMI in order to upload the logs. I hope it logged everything)

The projector is showing it doesn’t support 1024x768 resolution, and the small display does not return EDID info. I don’t think there is a way to make it just automatically switch with the hardware you have. You would probably be better served by either picking up a small 1080p display for the secondary screen, or just not use a second display at all and just listen to music headless using a remote control app on a smartphone or tablet for music selection and control.

Ok. Thankyou for the help :wink:

Correct. It’s actually your adapter that is supplying EDID information, claiming to support 1080p60, 720p60 and 480p60. There is no way to blacklist 1080p for only one display. (That resolution must be wrong unless there’s a downconverter in the adpater). If you set the GUI to 1280x720p60, you may be able to use both the projector and screen with a small reduction in GUI quality on the projector.

Set up the whitelist when you are connected to the projector and don’t touch it while connected to the LCD or it will be re-set.

I’ve been doing some digging. Monitors don’t normally like 10-bit video. If you go:

echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

do you get a picture on the LCD? This may also work at 1080p.

Let us know and we’ll get that fixed.

to be sure I understood: should I ssh this command while the vero il connected to the LCD, right?
It’s just a temporary command, I’m not changing some config, right? This evening I’ll try it

Do it at any time. Output will be 8 bits on both displays until you re-boot.

Ok. I tried with the command, nothing changed. Then I tried lowering the resolution to 720p, and now the LCD worked. But of course the image was squeezed from 16/9 into 4/3.
Then i switched back to the projector and when I switched back to LCD I was greeted with LSD :sweat_smile:

I guess the adapter doesn’t like the switching… No problem, I’ll get rid of that old LCD (or try to find another use for It… :thinking:).

Thanks anyway!

LOL. That’s probably fixable - if your projector is happy to accept RGB instead of YUV, set vero to output RGB all the time (Settings-System-Display). Also, put this line in /etc/rc.local:

echo 8bit > /sys/class/amhdmitx/amhdmitx0/attr

The code currently doesn’t cater for switching between an RGB display and a YUV display (maybe it should but that will take a while to do).