Auto update failed but no manual update available

Got a pop-up for an update being downloaded and ready to install. I hit okay and was waiting for the update the complete. however the update failed with “an error occurred while installing the following package: (unknown package)” and BSOD-ed.

But before jumping on to the forum, I tried a manual update and the manual updated reported that no updates are available, even though there was some sorta download happening on the top right corner. The funny thing is, My OSMC reports the version as 2017.07-1, which I am guessing is the latest version. So if the update is failing how am I ending up with the latest version?

BTW I am on RPi3, 16GB sandisk ultra, running out of a 2A mobile charger (before you shoot me down with power issue, I rarely see the lightning bolt show on the screen)

As any responsible netizen would do, I looked up the forum for similar issue. I found one here and re-installed perl using the instruction provided and then attempted a manual update again, but nothing happened (may be cause I am already on the latest version?!)

Anyway here is the log of the restart & manual update attempt after reinstalling Perl.

I also had a few BSOD’s even before this update issue. They were mostly during searching from add-ons (different add-ons) & once while trying to exit kodi from the Power options.

Kodi log is useless for apt. We need to see grab-logs -A which will include the apt logs.

Thanks, I am pretty new to this. so I just run it and give the output or do you want me to perform certain things before and then get the output?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

1 Like

Thanks Sam, I did go through those instructions before starting this thread and thought that I have covered everything, but apparently not. The only 2 things I seem to have missed are,

On demand recreation - No, I can’t recreate the issue on demand.
Peripherals attached - A usb mouse dongle

I didn’t get a grab output since it was mentioned as for a scenario where Kodi wouldn’t start but looks like apt logs are needed, will get it once I get home from work.

Here it is.


Edit: added log grabs

I can’t see anything in the apt log showing what went wrong but it seems that the My OSMC update code believed there was a problem since it didn’t run the next step to remove the old (4.9.29-5) kernel image.

I see that you later manually ran an apt-get autoremove, which completed this missing step.

yea, I ran apt-get autoremove as part of my uninformed attempts to reinstall perl. anyway I am just curious how the version ended up as the latest but still the update failed :confused:

That would be an issue for the developers to look at. According to the APT log, the update seems to have succeeded but perhaps the front-end code detected an issue that’s not apparent from the log or it misinterpreted something as suggesting a failure.

Edit: I wouldn’t be quite so confident about the power supply being sufficient.

I have an official Pi3 power supply and I never see a lightning bolt. Ever. It looks like you’re running a little bit close to the limit.