Autofs issue

Hi Folks,

I have the Vero 4K+ playing files beautifully from a hard drive, I have also set up UPnP, which can be hit and miss, so I would like to set up autofs. I have followed the tutorials and researched the various threads but am still hitting a dead end. This is my set up:

Windows 10 PC

IP address
PC name is ‘Desktop’
My account name is ADE WRENCH
I use a 6 digit pin to access windows on startup
I have an internal HDD which has the letter D: assigned to it. The folder I would like to share is on that drive and is called ‘Movies’, it is set up for sharing.

Vero 4K+

IP address
Username and password are OSMC
I have installed Samba from the app store
I have a fresh install ready to go

I have followed fzinken’s tutorial and everything seems to be fine until I test the shares, which then gives me the ‘no such file or directory’ error. Could you please check my powershell command lines are as they should be.

First of all the share command.

/mnt/Desktop/Movies -fstype=cifs,rw,vers=3.0,credentials=/home/osmc/.smbcredentials,iocharset=utf8,uid=osmc,gid=osmc ://

second, the credentials.

username=ADE WRENCH
password=<6 digit pin>

I then restart autofs and run the test command and get the following:

ls: cannot open directory ‘/mnt/Desktop/Movies’: No such file or directory

This is as far as I get, any help much appreciated,


You are on thin ice with a username with spaces in it. You could try
username="ADE WRENCH" or
username=ADE\ WRENCH

password means password, not PIN.

You could add a user in Windows - say osmc - and make sure that user is allowed to see your Movies. Warning - don’t use the default password for that user.


I have just created a new account with a username with no spaces and a password not a pin.
I have set up the relevant sharing options and permissions for the movie folder.
I have edited the credentials file in powershell to reflect the new user account.

Still get the same error.

Not sure what you mean by powershell - that’s a Windows name.

Can you post here the response to:

cat /etc/auto.master
cat /etc/auto.smb.shares

Sorry, I meant I used powershell to access the vero from PC and then edited the credentials file.

Here is the output you asked for:

osmc@osmc:~$ cat /etc/auto.master
# Sample auto.master file
# This is a 'master' automounter map and it has the following format:
# mount-point [map-type[,format]:]map [options]
# For details of the format look at auto.master(5).
#/misc  /etc/auto.misc
# NOTE: mounts done from a hosts map will be mounted with the
#       "nosuid" and "nodev" options unless the "suid" and "dev"
#       options are explicitly given.
#/net   -hosts
# Include /etc/auto.master.d/*.autofs
# The included files must conform to the format of this file.
# Include central master map if it can be found using
# nsswitch sources.
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
/- /etc/auto.smb.shares --timeout 15 browse

osmc@osmc:~$ cat /etc/auto.smb.shares
/mnt/Desktop/Movies -fstype=cifs,rw,vers=3.0,credentials=/home/osmc/.smbcredentials,iocharset=utf8,uid=osmc,gid=osmc ://

Sorry if these look crap, I just copied and pasted from powershell.


Try vers=2.1. That’s working for me here.


Sorted, thank you so much!

Can you please tell me why changing to vers=2.1 worked and is that something that is likely to change?


I don’t know - it’s all voodoo. 2.1 gives you a reasonable level of security I understand. As long as you don’t use 1.0 and have your share exposed to the interweb you should be good.

:grin:Got it,

Thanks again.