Autofs mount NFSv4 is not working with 2023.12-1 anymore


I have been using autofs for a long time to automatically mount NFS shares on boot (using Vero 4K). I configured autofs to use NFSv4 which has worked fine in the past.

After upgrading to 2023.12-1 it is now not working anymore. I recognized this, because my firewall only allowed NFSv4 and osmc was not able to access the share anymore. When allowing NFSv3, the share is mounted, although NFSv4 is configured.

This is how it isconfigured:

sudo apt-get install autofs

sudo nano /etc/auto.master, append:
/- /etc/auto.nfs.shares --timeout 15 browse

sudo nano /etc/auto.nfs.shares

sudo nano /etc/autofs.conf
mount_nfs_default_protocol = 4

sudo systemctl restart autofs

sudo systemctl status autofs

Does anybody know what was changed in the december update that could cause this behaviour?

Best regards,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I don’t know the answer but I do find I have to sometimes restart nfs-server on the server before restarting autofs on the client. That’s even if other clients are connecting OK.

@grahamh: Thanks for your support. Restarting nfs-server did not change anything. And I have another Vero, which is still able to access it.

Probably autofs-package has changed during the osmc-update and now behaves differently. I traced network traffic and see that the working Vero (without december update) is only using port 2049 for NFSv4 as it should be. The non-working Vero (with december update) is trying to determine the port through portmapper (port 111), which is not allowed in my firewall.

I forced using port 2049 by adjusting auto.nfs.shares

/- /etc/auto.nfs.shares port=2049 --timeout 15 browse

I don’t know why that autofs-behaviour was changed but with port 2049 in configuration as described above, portmapper is not used anymore, so mounting is working again.

Best regards,


There are a couple of bug reports on this topic on autofs mailing list or ubuntu bug tracker. It’s not totally clear if it is a bug or if new behavior require the definition of the port parameter if port 111 is blocked.
Also seems there was another issue with the net autofs version 5.1.8 but assume that will be fixed by the time it reaches debian stable.