Autofs on new Vero V

Hi, upgrading my vero 4k to the vero V today. Was hoping for a smooth ride, but autofs is giving me problems. I’m installing it the same way I’m doing on the vero 4k (and as described in the autofs install thread)
But it can’t find it
But when testing the mount, I get this error :

Starting automounter version 5.1.7, master map /etc/auto.master
using kernel protocol version 5.02
lookup_nss_read_master: reading master file /etc/auto.master
do_init: parse(sun): init gathered global options: (null)
lookup_read_master: lookup(file): read entry +dir:/etc/auto.master.d
lookup_nss_read_master: reading master dir /etc/auto.master.d
lookup_read_master: lookup(dir): scandir: /etc/auto.master.d
lookup_read_master: lookup(file): read entry +auto.master
lookup_nss_read_master: reading master files auto.master
do_init: parse(sun): init gathered global options: (null)
lookup_read_master: lookup(file): read entry /-
master_do_mount: mounting /-
automount_path_to_fifo: fifo name /var/run/autofs.fifo--
lookup_nss_read_map: reading map file /etc/auto.smb.shares
do_init: parse(sun): init gathered global options: timeout
mounted direct on /mnt/ with timeout 300, freq 75 seconds
do_mount_autofs_direct: mounted trigger /mnt/
mounted direct on /mnt/ with timeout 300, freq 75 seconds
do_mount_autofs_direct: mounted trigger /mnt/
st_ready: st_ready(): state = 0 path /-
handle_packet: type = 5
handle_packet_missing_direct: token 2, name /mnt/, request pid 4399
attempting to mount entry /mnt/
lookup_mount: lookup(file): looking up /mnt/
lookup_mount: lookup(file): /mnt/ -> -fstype=cifs,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0 ://                                                                                                                                        esG/
parse_mount: parse(sun): expanded entry: -fstype=cifs,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0 ://
parse_mount: parse(sun): gathered options: timeout,fstype=cifs,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0
parse_mount: parse(sun): dequote("://") -> ://
parse_mount: parse(sun): core of entry: options=timeout,fstype=cifs,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0, loc=://                                                                                                                                                        viesG/
sun_mount: parse(sun): mounting root /mnt/, mountpoint /mnt/, what //, fstype cifs, options timeout,r                                                                                                                                                        w,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0
do_mount: // /mnt/ type cifs options timeout,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0 usin                                                                                                                                                        g module generic
mount_mount: mount(generic): calling mkdir_path /mnt/
mount(generic): calling mount -t cifs -o timeout,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0 // /mnt/                                                                                                                                                        /MoviesG
>> mount error(22): Invalid argument
>> Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

Did I forget to do anything else?
It’s a fresh vero V, haven’t installed anything yet … instead of ofcourse autofs and the necessary auto.smb.shares file and auto.master file.

The mount -t .... call in you log seems to be truncated - is that just a log/terminal width quirk?

Can you post cat /etc/auto.smb.shares?

yeah it’s a quirk … I did a copy paste from putty

here you go … I copied that file from the vero 4k to the new one, so no typos should be possible from that part of view

/mnt/ -fstype=cifs,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0 ://
/mnt/ -fstype=cifs,rw,username=xbox,password=xbox,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0 ://

(can’t seem to paste them on 1 line here …there is a space between the sharename and -fstype)

Did you actually install autofs?
That was something I forgot when I got the V.

[edit]nvm, from the logs it seems you did[/edit]

Like I said, I followed the instructions :slight_smile:

sudo apt-get install autofs

sudo nano /etc/auto.master

add : /- /etc/auto.smb.shares --timeout 15 browse

I don’t think another package needs to be installed ?

True, only autofs is needed

OMG … I am a total … well, half… idiot …haha

Checking my files again, and mind you, I am a linux noob … for the auto.master file, I copied/pasted the /- /etc/auto.smb.shares --timeout 15 browse line in putty … but it seems the “15” part was not there.

added that … restarted autofs and I see my shares.
Apologies for my own error :slight_smile:

Now to just get my harmony remote working again (did the exact same thing as on the vero 4k, but so far no luck) … and I’m in business to test this baby

1 Like

I’m having problems getting the auto-mounts to work. On my Vero 4K+ all is flawless, but the V is giving headaches. I also followed the instructions, and all seemed fine. Checking the install with “ls -lah /mnt//” gave a perfect list of my shares. But on the Vero V the list under automounts is completely empty, when I try to add my media. Got no clue how to continue…

When I add media via Add video source/Browse/Root filesystem/mnt// I cán access my media. Just not when I try Settings/Media/Library/Videos/Auto-mounted drives, then the list is empty. Since I intend to use this install on my Vero V for a long long time, I want it perfectly installed and no quirks, so any help is appreciated !

On a completely fresh install (just out of the box) I tried to install the Java Runtime Environment from the OSMC Store. It failed, with an error. Can that be an issue?

on the vero when adding videos … did you go to ROOT, and then under the directory MNT … there you should find them

This thread is about autofs so unless you are referring to mounts that you created via autofs I suggest you start a new thread