AutoFS Only Shows 1 Folder

Hi. I’m having trouble adding a second network (SMB) source for my Vero. Serving files from my Windows 10 PC. Streaming to my Vero 4K.

My /etc/auto.master

/- /etc/auto.shares --timeout 15 browse

My /etc/auto.shares

/home/osmc/Network/PAPI1 -fstype=cifs,rw,credentials=/home/osmc/.smbcredentials,iocharset=utf8,uid=osmc,gid=osmc,vers=2.0 ://
/home/osmc/Network/4KHDR1 -fstype=cifs,rw,credentials=/home/osmc/.smbcredentials,iocharset=utf8,uid=osmc,gid=osmc,vers=2.0 ://

The first line is successfully mounted and all folders inside are seen. The 2nd line is mounted but only 1 of 2 folders are seen. When I check on windows explorer \\localhost\4KHDR1, it shows both folders.

Did I do something wrong?

Check your file permissions in Windows and make sure the user account your using to access the share from the Vero has rights to view that folder.

I’m assuming this folder name doesn’t end with a $ or begin with a . (period) which would make it hidden by design.

1 Like

No dollar or dot in the string. Simply “Movies” and “TV Shows”.

Checked all permissions, parent and children. All have read, write, full control enabled for Everyone.

From the Vero, try doing a

ls -la ~osmc/Network/4KHDR1

and then do:


and share the output.

1 Like

ls -la ~/Network/4KHDR1


It’s mounted OK. Can you show what the contents are from the Windows system?

EDIT: also please (from the Vero) do:

ls -lah ~osmc/Network/4KHDR1
1 Like

just to add, did smbclient -L -d 5 and here’s the output

contents from the windows system

Hmm, I see one thing here (and I wish you’d paste text instead of images because it would be so much easier to look at):

From the smbclient, the share is 4kHDR1 but in autofs you are using 4KHDR1

Linux is case sensitive, and that may be causing some odd issues.

1 Like

ls -lah ~/Network/4KHDR1

sorry. Will paste text next time.

Try fixing the auto.shares to fix the case problem.

1 Like

Done renaming 4kHDR1 to 4KHDR1 and result is the same

So you just renamed the share instead of changing auto.shares?

Does the ‘TV Shows’ directory contain the expected content?

I see that there is a different ‘TV Shows’ share, is that the same directory?

I renamed the volume name from 4kHDR1 to 4KHDR1, then went to auto.shares to replace :// to 4KHDR1. Then restarted the Vero

Yes, TV Shows share is the same folder as the TV Shows folder inside 4KHDR1

Yes, content of TV Shows contain expected content.

EDIT: Restarting both Vero and PC again. And same result. Only TV Shows, no Movies folder.

I just noticed something, and I don’t think that the share is actually mounting on the Vero (I missed that).

From you first post, the autofs entry was 4K, not 4k so now I’m getting confused.

Let’s try this, from the Vero:

sudo umount ~osmc/Network/4KHDR1
ls -la ~osmc/Network/4KHDR1
1 Like

Don’t worry. I’m confused as well hahaha. I think for SMB, everything is uppercased automatically. But now I’ve renamed both shared volume and auto.shares entry for consistency. Sorry about that.

I tried unmounting and doing ls -la and still same result. Only TV Shows and System information are present.

EDIT: Do you think changing to SMB v3 will do any good?

Then you have a local copy of TV Shows on the Vero! You are not mounting the windows share from what I can tell.

Instead of mounting to ~osmc/Network, try changing autofs to mount to where we recommend, /mnt and see what happens.

Just to be sure, I’d like to see the output of mount again.

ok. so change from ~/Network/4KHDR1 to /mnt/4KHDR1?

EDIT: Shouldn’t ls re-engage the mount? Because that’s what autofs does right?

Change your auto.shares to use /mnt/4KHDR1, then reboot.

1 Like