Automatically playing next title no longer works

Hi all,

This might be something simple I’m overlooking but I can’t seem to make it work.

I’ve been using OSMC on the RasPi2 for quite a while now, and always have the “automatically play next title” option selected; I can just leave an entire series playing that way. Suddenly, over the past couple of days, that no longer works. Instead, at the end of a show I’ll get a small “play” icon at the bottom right of the screen with a circular bar around it counting down to playing another episode - but it ALWAYS picks completely the wrong episode.

For example - I’ll play Frasier Episode 1 Season 1, and when it’s finished it’ll leap to … Series 3 Episode 1. If I play any episode from any season of Castle, it’ll always try to autoplay some episode from (I think) Season 2. More often than not with many series it’ll just stop at a black screen, presumably as it can’t find what it’s trying to jump to.

I haven’t changed any settings at all, and can confirm that the HDD connected is error free as I’ve checked that also; the problem also isn’t happening on my other RasPi2 which is also running OSM, so I’m genuinely confused.

Does anyone have any suggestions? :smile:

  1. how is the HDD connected (direct in USB socket, wired, NAS …)?
  2. do the Pi’s share a database?
  3. are the Pi’s on the same version/update?


  1. The HDD is connected directly via USB to the Pi.
  2. They don’t - the other Pi simply finds the first one (with the HDD connected) over the network and uses it’s library.
  3. That’s a very good question. I haven’t told either of them to update recently, but I’ll take a look at that once I’m home. However, the second Pi doesn’t have this issue - in fact, the “play next title” option has never worked on it, but we don’t need it to on that one :smile:

Thanks for the feedback!

Something not quite right here
first post: “the problem also isn’t happening on my other RasPi2 which is also running OSM”
second post:‘the “play next title” option has never worked on it’


Apologies for my poor choice of wording :smile: Getting distracted at work.

The problem as described is happening on the RasPi2 with the USB attached drive.

“Play Next” title has never worked on the other machine, but that’s not an issue and I don’t need any help with it - I only ever use that one to watch an individual title anyway, so for me it’s not an issue. By “problem also isn’t happening on my other RasPi2” I meant that it wasn’t trying to auto-skip to a seemingly random episode somewhere, not that it had no problems at all - but I could have phrased it better.

Hope this clarifies things!

I think now we have a clearer idea of the problem, but you may need to post debug logs to assist someone to focus on the problem.

When I got home I took a closer look and, as it turns out, the problem was caused by something someone has changed - that’ll teach me to leave my phone lying around with the remote control app!

They’d enabled the “Next Up” add-on which was helpfully trying to inform me what was coming up next; however, as they hadn’t configured it, it wasn’t working properly. I’ve disabled it now, and the problem’s gone away.

Thanks for the help anyway! :smile:

Glad to hear it’s sorted