Automounted USB drive renamed, need help please

Hello all. I can’t for the life of me figure out how to resolve this issue I am having.

I have a 8TB HDD that is auto mounted. The drive is usually mounted to media/8TB, but for the last few days it is being mounted to media/8TB_

Even if I unplug the hdd and restart osmc, the “mount” of 8TB is still in media. I am guessing for some reason the media/8TB mount is persistant, and therefore renames the HDD to 8TB_

I would love to get this figured out and have my 8TB drive mount back to media/8TB instead of media/8TB_

I have a lot of devices and programs looking for the path media/8TB. I tried keeping the drive unplugged rebooting osmc, and removing the media/8TB dir, but i get permission denied.

Any advice would be greatly appreciated. Thank you for your time.

I figured it out.

I ran
sudo rm -rf /media/8TB
And it let me delete the entry. Drive is properly mounting back at media/8TB now.

Wonder why this happened in the first place?

Most likely an unclean reboot/unmount left the entry there.

1 Like