Autoplay problem with BR DVD USB player

#1

I have a self-powered Blue-Ray DVD player (LG BE16NU) connected to Vero4K. In the beginning no problem with autoplay of audio CD’s en DVD’s. In recent months autoplay is not working anymore and I see buffer I/O errors in the log when inserting an audio CD https://paste.osmc.tv/zotilitabu

If I mount a DVD I can see it in the video files and start it from there.

Strange thing is that this DVD player is working without any problem on a Windows 10 pc with the same audio CD’s or DVD’s.

Anyone can help me ?

0 Likes

#2

[ 68.794355] Buffer I/O error on device sr0, logical block 0

A few possibilities:

  • Disc is damaged (unlikely)
  • There is a power issue – and the drive isn’t getting enough power
  • There’s some sort of copy protection active.

Do you have a CD that won’t be protected (such as a software disc) that you could try?

Sam

0 Likes

#3

Hi Sam,
thanks for your feedback.

I have tried with a software disc and this is working allright without buffer I/O errors.

Jan 05 16:15:00 osmc kernel: scsi 0:0:0:0: CD-ROM            HL-DT-ST BD-RE  BE16NU50  1.01 PQ: 0 ANSI: 0
Jan 05 16:15:00 osmc kernel: sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
Jan 05 16:15:00 osmc kernel: cdrom: Uniform CD-ROM driver Revision: 3.20
Jan 05 16:15:00 osmc kernel: sr 0:0:0:0: Attached scsi CD-ROM sr0
Jan 05 16:15:01 osmc ntpd[946]: Soliciting pool server 194.78.244.172
Jan 05 16:15:02 osmc ntpd[946]: Soliciting pool server 2001:6a8:2500:100::153
Jan 05 16:15:06 osmc systemd[1]: Time has been changed
Jan 05 16:15:06 osmc systemd[1]: apt-daily.timer: Adding 11h 42min 39.332857s random time.
Jan 05 16:15:06 osmc systemd[1]: apt-daily-upgrade.timer: Adding 8min 42.454684s random time.
Jan 05 16:15:10 osmc bluetoothd[782]: Endpoint unregistered: sender=:1.48 path=/MediaEndpoint/A2DPSource
Jan 05 16:15:10 osmc bluetoothd[782]: Endpoint unregistered: sender=:1.48 path=/MediaEndpoint/A2DPSink
Jan 05 16:15:26 osmc performance_tuner[384]: /: 11.1 GiB (11912728576 bytes) trimmed
Jan 05 16:15:30 osmc udisks-glue[581]: Device file /dev/sr0 inserted
Jan 05 16:15:30 osmc udisks-glue[581]: Trying to automount /dev/sr0...
Jan 05 16:15:31 osmc kernel: ISO 9660 Extensions: Microsoft Joliet Level 1
Jan 05 16:15:32 osmc kernel: ISOFS: changing to secondary root
Jan 05 16:15:32 osmc udisks-glue[581]: Successfully automounted /dev/sr0 at /media/CyberLink
Jan 05 16:15:32 osmc udisks-glue[581]: Device file /dev/sr0 mounted at /media/CyberLink

So, maybe a copy protection issue ?
The drive has its own power supply, so I don’t think it isn’t getting enough power

0 Likes

#4

I think the issue is that Kodi needs to open it as CDDA.

We do build Kodi against libcdio; but I note we pass --disable-optical-drive. I think this is because we expect UDisks to handle things; but it won’t be able to handle an audio CD.

I can produce a test build if you’re willing to give it a go.

Sam

0 Likes

#5

Seems related to:

commit c4161c7c253b2a5ac3268ec92fa73906608ebbe6
Author: DBMandrake sbyrnand@gmail.com
Date: Mon Jun 1 14:50:37 2015 +0100

[package] [mediacenter-osmc] Disable Kodi’s built in disk mounting to ensure only udisks-glue handles mounting and also prevent Kodi closing a disc tray immediately after ejecting it. Add depend on a version of diskmount-osmc that supports mounting optical disks.

0 Likes

#6

hello Sam,

Sure, I am willing to give it a go with a test build.

Thanks in advance

0 Likes

#7

As I read the specs for the quoted model, it gets power through its USB connection!
Derek

0 Likes

#8

hi Derek,
I have to disagree with you : the drive has a power connection with AC adapter.
See owner manual on https://www.lg.com/us/support-product/lg-BE16NU50

0 Likes

#9

Thanks for the info - the specs detail suggested otherwise, with no mention of separate PSU.
Derek

0 Likes

#10

Checked this – I don’t think a new build is needed.
Can you change ‘handlemounting’ to 1 in advancedsettings.xml?

<?xml version="1.0" encoding="UTF-8"?>
<advancedsettings>
    <handlemounting>1</handlemounting>
</advancedsettings>
0 Likes

External audio CD reader
DVD playing failure
#11

Sam,
perfect ! that solved the problem :blush:

audio CD’s are playing fine now.

thanks for your time.
Geert

0 Likes

#12

Thanks for letting me know.
I will need to think about a proper solution

Sam

0 Likes