AV receiver: selecting OSMC HDMI channel wakes up the AV receiver


I’m building a new system with my first AV receiver (Denon if it matters), connections are RPI>AV receiver. The CEC is enabled and works fine, I’m able to control OSMC with the remote of my Sony television.

The problem: on the Sony TV, when I switch to RPI HDMI input the AV receiver automatically wakes up, what I don’t want. The RPI is never switched off (24/7 on), it not a problem originated from the RPI power on. Simply switching to the RPI input makes it happen. Under OSMC peripheral CEC, all settings related to the power on of the device are off. On the Sony TV the linked power off are disabled too. I just don’t want to wake up the AV receiver when I switch to input to RPI, but cannot tell even from where the wake up signal comes from

Anyone with a similar setup ?

(for the record)
Brain night processing involved I think I get it. As said it’s not a RPI power on issue as read on many topics, mine still always ON. Reviewing the Kodi/AV receiver settings doesn’t help too. I finally found a Sony TV submenu giving preference to external speakers if present. Read this option as “CEC power ON message for selected input”.
Switching this option off this morning gave me right behaviours (do not self power on the receiver in any way)


1 Like