Avi and mp4 media not playing

I have, what I hope is, the latest OSMC installed and it does not play media I have created via ffmpeg on my Debian Jessie laptop. The files are .avi as well as .mp4 & play fine on my laptop.
This media was created from still images I took from my cell phone via ip webcam.
Please tell me where I should start looking for a solution.
BTW The command I used to create the avi was:-
ffmpeg -r 2 -framerate 1 -pattern_type glob -i ‘*.jpg’ -c:v libx264 -pix_fmt yuv420p 20151102.avi

Does it work if you disable omxplayer and MMAL in video/acceleration settings?
Can you post mediainfo of one of the files?

Please tell me where I find video/acceleration.
I have searched on the command line for video as:-
sudo find / -name video
[sudo] password for pi:
/lib/modules/3.18.10-1-osmc/kernel/drivers/video
/usr/share/kodi/addons/skin.confluence/media/flagging/video
/usr/share/kodi/addons/skin.osmc/media/flagging/video
/usr/share/kodi/system/library/video
/home/osmc/.kodi/userdata/playlists/video

but when I search for acceleration I find nothing.
sudo find / -name acceleration

Secondly please tell me how do I get the mediainfo of those files.

Does AVI video (video/x-msvideo) and ITU H.264 and
MPEG-4 video (video/mp4) & H.264 help at all?

http://kodi.wiki/view/Settings/Videos#Acceleration
https://mediaarea.net/en/MediaInfo

1 Like

Thank you

Mediainfo I have taken a screen dump of what mediainfo tells me but how do I send you these images?

OK I decided to place the screenshots on my server at http://devacs.za.net/images/Screenshot-mp4.png and http://devacs.za.net/images/Screenshot-avi.png
and now my question is should I create the media using a different method?

I’m sure @popcornmix will be along soon to comment on those mediainfo’s but they look pretty odd to me!

3264x2448 pixels is way too high for the Pi to play as far as I know - it can support up to 1920x1080p. Also your mediainfo claims 1fps (frame per second) which seems bogus as well…

Yes, Pi won’t play more than 1920x1080 videos. (I doubt many embedded platforms will).
It also won’t play 4:2:2. Make it 4:2:0.

Technically it probably will play level 5.1, but you should really limit the level to 4.1 if you want it to play on most players. BluRay is level 4.1, so unless you are after higher quality than BluRay, then stick to 4.1.

Thank you and now I have the solution and the avi is working fine.