AVIs have audio and video out of sync after upgrade to Kodi 19.1

Hello!
Is this a known issue? After the upgrade, I am facing sync issues with AVI files. Not the case with MKV files. I did a quick search in the forum and didn’t see any related recent entry. Thanks!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thank you very much for the answer.
I followed all the steps and here are the requested files: https://paste.osmc.tv/ugifaqokab

I reboot twice. Then I selected series, a specific one from the list, and pushed play. It started and I stopped it after 1 minute. As I said, the video and audio are out of sync. It happens with all AVI files I tested. It doesn’t happen with MKV files.

Before the upgrade, this didn’t happen. I suspect there has been a change in installed codecs perhaps?

Well, there are all the logs. I hope you can help me detecting the issue. I will have to reinstall the old version if it is not solved, so thanks a lot for your help.

Ok, investigating a little bit myself within the settings I found “the issue”.
The sync issue disappears if I unselect: “Allow hardware acceleration with DRM PRIME” or having it selected but then also select “Only allow acceleration for HEVC”.

Does it make sense? Any idea why does it happening? I am not an expert, I don’t know what DRM PRIME does and why it should affect to AVI files. Is it anything new in this update?

BTW, I am using a Raspberry Pi 3.

Thanks again!

New issue. If I do what I explained above I fix AVI files but I break MKV ones. :-/
So I need to touch that setting each time, it depends if I am going to see an AVI or a MKV file.
Any idea or suggestion why is this happening?
Thanks!