Backup done but how to restore

I used the Backup utility in OSMC (in the Update section) to manually make a backup of all settings and place it in a folder on my NAS. The Backup is done and I can locate the file on the NAS (~130MB).

When I try to make a manual restore, I can see the file but when I click it, there is no response. The ‘browse’ window disappears and nothing happens. So I try to run a manual restore again, but this time there is no file to choose but rather a window asking what sections to restore. It seems like a followup selection window to the first restore process I started. So I choose ‘All’, but again the window disappears and nothing happens. No progress bar, no indication the restore is working in the background, nothing. So I run manual restore again, and it immediately display an error that not all settings were restored!

What am I doing wrong?
How do I properly restore a full backup?

Rather than browsing for the backup, try going into the backup preferences and changing the backup location to where your backup is stored.

Then when you go to restore it should find the location of your existing backup automatically and let you select it without using a file browser.

Ok I saved my backup location on the NAS in the configuration and now when I choose manual restore, I see my backup file without browsing.

But I still have the same problem, which is once I choose that backup file, nothing happens. The window closes and I’m returned back to the myOSMC display and nothing else happens. I waiting for 15min thinking maybe the backup is done in the background but nothing happened at all. The backup file is 132MB, so I think 15min is enough to copy it and install it. In the configuration window I choose to backup everything except the thumbnails.

I try to run another manual restore after that but nothing happens at all. Not even the window to choose the backup file.

Any help?

For the time, I’m forced to make an image of my entire SD Card to have a full backup of my setup. It’s not convenient because it’s time consuming and it creates a 16GB file on my machine every time I do it.

I would appreciate any help to get the OSMC backup and restore working.
Thank you.

Now, after you configured your backup location, can you delete the old backup and create a new one.
After that, open the backupfile with an archive software like winrar or winzip and verify that there is a folder/files structure.
Maybe also try to restore the backup with the use of the default skin.

I don’t know if that could help, but that’s what I would do.

good luck :wink:

I deleted all backup files, and created a new manual backup. Backup everything except the Thumbnails. Extracted the ‘tar’ file, and found 2 folders “addons” and “userdata”, with total of 190MB uncompressed.

When I go to make a restore, I choose the file on my NAS but nothing happens! I leave it for a while but nothing. I try to run another restore and nothing happens, not even the window to choose the backup file.

I am using the default Confluence skin.
I have the OSMC june update done.
Using RPi3.

Any ideas?
Anyone tried backup and restore functions successfully?

I’ve been using the backup program add-on… In earlier days the OSMC backup did not work across SMB… The add-on solved this. It has worked so well (across rpi 1, 2, 3, Vero 1, Vero 2) that I’ve not tried the built in function.

Thank you for suggesting the Backup addon. I installed it and it’s working successfully.

Not sure if I should tag this thread as solved or not as my original post was regarding the OSMC Backup utility which still doesn’t work for me.

I have similar problem! “Back up fail to copy tar file”, " not enough space on usb device" (i’ve tried with a 128G and still same message). I’ve did not solve this problem since the june up date!

Yesterday I also tried the backup for the first time to move to another SD.
Altough I selected to also include Thumbnails into the backup, they were not in.
When restoring the backup on the fresh new SD, I got an error, that not everything could be restored.
After copying manually the complete Thumbnails folder from the former SD, some movies still have no cover or fanart.
The second user with its settings also has not been restored at all.

This way the backup is hardly usable. It could save a lot of time, but with the current status you end up copying everything manually anyways…

Hey KL1,

I’ve read through a few threads where you have mentioned this and I too ran into the same issue.

I mounted the NFS store and told it to backup from XXXXX file selection.

After roughly three minutes, it popped up and asked what I would like to restore, to which I selected everything.

During the three minutes, I was sure that nothing was going to happen and was surprised when it popped up.

After I selected everything to restore, it then acted the same way. I am now waiting to see if it will pop up eventually and tell me it is done or not. I’m wondering what log file we could tail via SSH to see this progress.

I’ll update if anything more happens.


After another three, or so, minutes I received a pop up stating that not all items could be restored and then it prompted me to reboot, which I did.

I’m unsure what items failed to install. Everything, including my advancedsettings.xml file was restored and I can’t seem to find anything missing.