Backup is filling /temp up until sd card is full

Sometime I got a popup message saying there is not enough space left for a Backup. First I was wondering, how can this be true, since the backup dir is on my NAS and there is plenty of space left.
So after some research I found out, that the backup first copy a compressed file into the /temp dir.

There where like 4 such files, which filled my SD card fully. So I cleaned out those files over SSH. But after sometime I run into the same problem again!
OSMC is up-to-date.

Any ideas why this might happen?

The backup must be created locally first before moving it to the NAS. This is a limitation of the utility currently.

Hi sam

I understand what you are saying. But why they get not cleaned out of temp once the on my NAS?

Are you sure they’re being created in /temp and not /tmp?

/tmp should be cleared each reboot.

I can ask @Karnage to delete the temporary file after it has been moved to the destination

I’m not 100% sure but I would say the files I deleted were in ~/.kodi/temp

Maybe it would be a good idea to clear the whole temp when OSMC reboots.

Clearing ./kodi/temp on boot is not a good idea, as the previous kodi log is maintained there, and can be used for debugging purposes.

Ok maybe just some glitch. I did manually trigger the backup yesterday. The first time I got the sad face screen (no idea why, OSMC is running stabil on my raspi 2) and the compressed backupfile were of course not removed. So I deleted that file by hand and tried again. This time the backup job did finish and the file in temp dir was nit there after the job finished.
I will monitor the job for the next few weeks. See how it goes.
Btw when will the june update released?


1 Like