Backup settings to USB? (to export to new Vero 5)

Hi guys - is there any way to do this? I can backup to my network drive but without any settings in the new vero it’s so complicated to find the network drive with a fresh install.


If you plug your USB drive into your old Vero it should automatically mount to /media/[something] so it should just be a matter of going into the My OSMC add-on>updates>backup> and set location entry method to “browsed” and then click on “click to browse” then >root filesystem>media>[something]> till you get to where you want to save your files then click OK. At this point you will want to click on OK to exit the updates screen and exit the add-on. Once back at the home window you will want to select power and exit to restart Kodi. There is currently a bug in the backup program where it only updates your backup location after Kodi has restarted. Once your back in Kodi you can go back to the previous location, configure which files you want to backup, then click the manual controls section to the left and select “run a backup of settings now”.

1 Like

thanks mate, awesome.

1 Like

OK, well that didn’t work. I backed up everything to the usb drive except thumbnails, that worked, then when I restore that backup onto the vero 5 nothing happens. It seems to sucessfully do the restore but no settings change and there is no library or anything present.

I ran into a similar issue where after I got real backup the restore to another device did not really seem to do anything or acknowledged the restore was complete.

That is unexpected. I ran a backup and restore from one Vero V to another like two weeks ago. Are you sure you had selected the items to restore when asked? I’ll see if I can find some time tomorrow to backup from a 4K and restore to a V just to double check. If you want some alternatives there is an add-on in Kodi’s repository called “Backup” and that will work for most people. It doesn’t have options for backing up autofs, fstab, and maybe something else external to Kodi (don’t remember off the top of my head) but if you don’t use any of that it wouldn’t matter. There is also the option of manually doing it over the network. You can install samba server from the My OSMC add-on and that will allow you to access and pull the .kodi folder over to another machine. To restore this way you would need to ssh into that machine and systemctl stop mediacenter and then you can transfer your files without Kodi locking anything.

@floatingkiwi @swanlee I’m at a loss to explain why you were experiencing issues. I ran a backup of the Vero V that I use as my primary player. I backed up everything but thumbs and profiles. I then restored that to a Vero 4K that had been recently clean installed and left mostly unconfigured. That restore worked flawlessly. I then backed up that 4K and restored it to a different Vero V that I had switched over to stock default userdata. That restore worked without issue as well.

There was an update to the My OSMC add-on a couple days ago so you might run the system update in My OSMC and then try a backup again. If it still doesn’t work please report back so we can try to sort out what the issue may be.

update: 21-dec. OK it seemed to work this time with most settings transposed across. However I now cannot access my shared files - none of the loaded folders works. So I can’t play anything…
AND… that blue led is terrible…

Did you do a system mount with autofs? If so then you will need to install it again like you did before. Otherwise you could post a log set so we can see exactly how your setup.

I’m really not sure, I know it was difficult… SMB I think.
I can navigate to the shared folder that I use for this on my NAS, in “My OSMC” when I am choosing the backup folder, so it can definitely see it. It’s just all my library shares/links that seem to be broken.

what would a “log set” entail?

Have a read through this and should put you on track.

1 Like

reboot twice and upload logs with the My OSMC add-on. If I can see how you have your sources and advancedsettings.xml configured it should be pretty easy to spot what your issue is.

I have just added new media libraries, not too bad this time around. so I seem to be sorted, for media at least. Having some of the other known issues too but will reply in pertinent posts.

1 Like