Backup vs Restore inconsistency

Tried the backup function this morning, overall worked well, but noticed something a little inconsistent: when setting a backup location, OSMC allows me to select an NFS location, which is what I used, to backup settings to my NAS. After reinstalling the Feb version of OSMC, I went to the restore utility, and there was no option to select a network location. I ended up copying the backup file manually to the /home area on the Vero via Windows Explorer, and then restored. Is this by design or an oversight? Seemed odd I could not select a restore location that had been permitted as a backup location.

By the way, does the backup utility also backup something like Samba? Or does that require a manual reinstall?

I am also missing the network restore options.
I can select my backups from the menu, but if i do a complete reinstall then it does not know these.

Seems more user friendly if there was the possibility to browse for network backups.

I am using the MariaDB for shared medialibrary.
Could this be included in the backup as well.
i also see that password.xml is not on the list of backup items.
Is this by design?

IIRC, it’s a limitation of Kodi, and you need to copy the backup to local storage as Kodi’s GUI doesn’t let us select network locations.