BBC iPlayer has stopped working


I have OSMC (Linux 4.9.269-9-osmc) running on a vero 4k+. I previously installed bbc iplayer addon and it was workingnfine, but it has now stopped working.

When I attempt to run a program I get the following message:

One or more items failed to play. Check the log for more information about this message

and the following output from the kodi log:

2022-10-15 17:36:58.769 T:2900     INFO <general>: CActiveAESink::OpenSink - initialize sink
2022-10-15 17:36:58.769 T:2900     INFO <general>: CAESinkALSA::Initialize - Requested layout: FL, FR
2022-10-15 17:36:58.769 T:2900     INFO <general>: CAESinkALSA::Initialize - set digital_codec 0
2022-10-15 17:36:58.770 T:2900     INFO <general>: CAESinkALSA::Initialize - Attempting to open device "default"
2022-10-15 17:36:58.776 T:2900     INFO <general>: CAESinkALSA::Initialize - Opened device "default"
2022-10-15 17:36:58.777 T:2900     INFO <general>: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2022-10-15 17:36:58.778 T:2900     INFO <general>: CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4
2022-10-15 17:36:58.780 T:2900     INFO <general>: CAESinkALSA::Initialize - speaker layout 0
2022-10-15 17:36:59.304 T:3307     INFO <general>: initializing python engine.
2022-10-15 17:37:06.132 T:3307     INFO <general>: CPythonInvoker(20, /home/osmc/.kodi/addons/ script successfully run
2022-10-15 17:37:06.232 T:2857     INFO <general>: VideoPlayer::OpenFile: plugin://
2022-10-15 17:37:06.326 T:3307     INFO <general>: Python interpreter stopped
2022-10-15 17:37:07.827 T:2857    ERROR <general>: CCurlFile::Stat - Failed: HTTP response code said error(22) for
2022-10-15 17:37:07.829 T:3310     INFO <general>: Creating InputStream
2022-10-15 17:37:07.830 T:3310     INFO <general>: AddOnLog: inputstream.adaptive: SetVideoResolution (1920 x 1080)
2022-10-15 17:37:08.488 T:3310    ERROR <general>: CCurlFile::FillBuffer - Failed: HTTP returned error 403
2022-10-15 17:37:08.491 T:3310    ERROR <general>: CCurlFile::Open failed with code 403 for
2022-10-15 17:37:08.491 T:3310    ERROR <general>: AddOnLog: inputstream.adaptive: Download failed:
2022-10-15 17:37:08.491 T:3310    ERROR <general>: AddOnLog: inputstream.adaptive: Could not open / parse manifest (
2022-10-15 17:37:08.492 T:3310    ERROR <general>: CVideoPlayer::OpenInputStream - error opening [plugin://]
2022-10-15 17:37:08.492 T:3310     INFO <general>: CVideoPlayer::OnExit()
2022-10-15 17:37:08.492 T:3310     INFO <general>: ADDON: Dll Destroyed - InputStream Adaptive
2022-10-15 17:37:08.514 T:2857     INFO <general>: CVideoPlayer::CloseFile()
2022-10-15 17:37:08.569 T:2857     INFO <general>: VideoPlayer: waiting for threads to exit
2022-10-15 17:37:08.569 T:2857     INFO <general>: VideoPlayer: finished waiting

I have tried rebooting, but that did not make any difference.

Does anyone know what might be going on here ?
My searches suggest that it is an idea to clear the cache - does anyone know how I can do that ?

For archived programs it seems to have started working again, so I can only assume the servers were either down or overloaded.

However I still cannot stream live programs (I do not think I have tried this before, so it may be that they have never worked).