Bbc iplayer not installing

I’m completely new to OSMC so forgive me if I’m asking silly questions.

I’ve set it up with the latest install on a Raspberry Pi3 and confirmed that all the latest updates are applied.

I’m trying to install iPlayer WWW (BBC iPlayer) like this: Settings -> Add-on browser -> install from repository -> Video add-ons. I scroll to iPlayer WWW and install.

However the task does not complete and it reports the following error in the top right hand corder of the screen:

“inputsream.adaptive version 1.0.6 could not be satisfied…”

I’ve tried hunting around the menus to find something else to install but not had any luck.

How to I get this inputstream.adaptive dependency?


Try enable it first in Kodi -> Addons?

okay I’ve fixed it.

There is a very well hidden option which I found by mistake here:

Settings -> Add-on browser -> My add-ons -> VideoPlayer Input stream -> inputStream Adaptive

You can enable it from here…

I’m wondering if the application installer can maybe set this option to make it easier. This wasn’t an easy thing to find!

iPlayer should depend on this.
And that dependency should be enabled automatically.

Might be worth mentioning this to the developer of the iPlayer add-on.


He’s known about this for at least a month, but I don’t think he’s planning to change it: Head to page 74 on the link below.

A lot of add-ons seem to use inputstream, or at least will do in the future. And it’s possible some of them won’t list the dependency as they may expect it to be already enabled.

I wonder if it’s worth enabling this add-on by default, in the same way we do for My OSMC.

@popcornmix, what do you think?

I found the repository for the code here and it looks like there is already an issue for just this point: