BD movie rips constantly buffering on latest release


I wanted to show Star Wars series to my GF today and as she does not know English very well I ripped the Amazon collection I have to add Polish subtitles.

To my astonishment the stream was unplayable (buffering every 5 - 10 seconds). I’ve never experienced this problem before and I remember playing BD rips previously.

My specs: RasPi 2, 8Gb SD, Wired Connection to 1Gb router, latest OSMC 1.10 (4.2.3-2-osmc)

Here are my Kodi logs (I’ve started playback and experienced 4 buffering freezes):

And here’s the media info of the ripped main m2ts file:

Please help.

There’s a lot of sync errors in the log suggesting it may be a bad rip with timestamp errors, however does it play OK if you enable OMXPlayer in Settings->Video->Acceleration ?

In overall it plays very ok, the only problem is this buffering every 10 seconds. I ended up hooking MacBookPro to my TV and the rip played flawlessly. I’ve noticed some buffering problems before on some higher bitrate MKVs (like buffering once in 10 minutes) but I did not care so much at that point. Now I can match buffering problem with some of the latest OSMC releases (I’ve updated some time ago from Kodi 14.2).

I’ve also looked at The log file and there are some caching state changes. What could be The source of it? I’ve tried several buffering configurations in advancedsettings.xml also with zero cache but it only helped a little or in case of zero cache made the playback choppy.

I’ve trie OMX player acceleration but the only thing it did is that it made pauses when the video was buffering without the notification that it is buffering. So no real help there …

Do you have room on the SD card to temporarily copy the file there and play it locally to rule out a network issue ?

I see you’re trying to play it using the built in SMB client in Kodi, which is certainly not the best when it comes to playing a high bitrate file like this.

This is definitely a network buffering issue. Playing from USB pendrive does not cause this issue. No buffering at all.
I’ve also tried NFS instead of Samba as a data source but no change and buffering happens in the same places :confused:

My question is why this problem appeared in one of the newest releases. I’ve never experienced network problems before.