Best calibration/resolution/refresh rate settings?

I just got a Vero 4K+ and really liking it so far. I’m only still struggling a bit with how I should configure the settings.

This is my setup:

  • LG C7 OLED TV
  • Vero 4K+ connected by HDMI to my (4K HDR passthrough capable) soundset
  • Soundset connected to my LG C7

I have the GUI resolution set to 1080p/60hz (Settings>System>Display>Resolution> 1920x1080p) and Adjust display refresh rate to On start/stop.

Now according to this this thread I should whitelist all supported resolutions and refresh rates. But according to this thread I should leave the whitelist empty.

My problem is that if I enable supported resolutions in the whitelist, I get microstutters during playback, probably due to some refresh rate errors? But if I leave the whitelist empty, then part of the screen ‘falls off’ only during playback. The GUI shows the screen perfectly and completely.

I have calibrated the screen in display settings, but it seems it only calibrates for one resolution and refresh rate. My TV picture scanning setting is set to Automatic, which I never had any problems with.

What are the best settings I should use for my setup?

Thanks!

First, we recommend you don’t attempt to calibrate the screen with Kodi. Set your TV’s overscan setting to off. Can’t remember what LG call it - ?Just scan. Yes, the calibration is for each resolution/refreshrate combination. It’s really only useful for CRT displays.

The only difference between turning on all resolutions in the whitelist and turning them all off is Vero will switch to resolutions below the GUI resolution if your display supports them. If you get microstutters with any particular (output) resolution, try turning that resolution/refreshrate combination off in the whitelist. That’s what the whitelist is for.

If I set my TV’s Scanning option to Off, then parts of the screen even fall off when I’m on the GUI as well (after I reset my display settings back to default). So I kind of have to use the calibration setting?

Sorry but will Vero switch to all resolution below the GUI when whitelist is on or empty? And what if the GUI is set to 1080p and I play 2160p videos?

If whitelist is empty, and adjust refreshrate is On Start/Stop, Vero will switch to the resolution/refreshrate of the video as long as it’s the GUI resolution or higher and supported by your display.

Can you show us logs so we can check your settings.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Just Scan is the option on LG

Thanks for the help. I play mostly 2160p and 1080p videos, and sometimes 720p or even 480p. So ideally I should set the GUI to 1080p and then whitelist only the 720p and 480p resolutions?

Here is my log: https://paste.osmc.tv/sosuyakijo

I only have the options: Automatic, On or Off.

I suggest you leave the whitelist blank and see how it goes. If you do get issues with 720p and 480/576p resolutions, then, yes, enable those in the whitelist but you will also have to enable all the other resolutions/refreshrates you wish to use.

The log shows there are no calibrations active, which is as it should be.

Set Just Scan to On

Okay thanks for the help. Video is now played in full without parts falling of the screen and also no microstutter.

But unfortunately I’m now noticing another issue. On most videos (not all) there’s a blurred line visible on the bottom or on the side of the screen. I made 2 pictures of it on 2 different videos: Imgur: The magic of the Internet
If I play those files on my PC with VLC there are no blurred lines visible and everything looks perfect.

How can I fix this?

If you whitelist anything at all, then you need to whitelist every output resolution that you want the Vero to be able to use.

I can’t really see what you mean from those pics.

Sorry, it is a bit hard to see on the pictures indeed. It’s much more noticeable when looking at it on the TV

I pointed some arrows at it: Imgur: The magic of the Internet

There’s a line at the edge of the frame that looks like it’s blurred. On some videos it’s on the side and on some it’s on the bottom.

Do you get the same when using the OSMC skin?

Yes I do. In fact, I just reset Kodi to defaults and it’s still showing…

Can you re-boot, play one of those problem vids and upload logs?

Here’s the log: http://paste.osmc.tv/wawivuxeyo

I did enable whitelisted resolutions again, since 4K HDR files were giving me microstutters when I left the whitelist empty. Playback now works well, except for the weird blurred line on the bottom or side of quite a few videos.

Thanks!

Microstuttering is now also happening at 4K HDR (with TrueHD audio) files when I select the correct whitelist resolutions and refresh rates (as well as when whitelist is left empty)… Adjust display refresh rate is still set to start/stop. I also tried playing a 4K HDR video with non-HD lower bitrate audio like DD5.1 but the stutter problem remains.

/edit: here’s a fresh log where the stutter happens: https://paste.osmc.tv/wugibeguxu
Adjust display refresh rate is set to start/stop and some popular resolutions+refresh rates are whitelisted (like 1080p/23,98hz - 1080p/24hz - 2160p/23,98hz - 2160p/23,98hz). It only seems to be happening to 4K HDR videos.

/edit2: I just tested it with the same file but now not played from my NAS but from a USB drive and the microstutter problem remains. It stutters even more frequently than when played through nfs from my NAS. From my limited knowledge of the log, it seems like ActiveAE::SyncStream - average error of 14.310407, start adjusting might be the problem. Anyone knows how I can get smooth playback without stutters?

I created a new topic solely for this issue of stutters: Microstutters on Vero 4K+

Is there a specific reason you’re using whitelisting?

You only need Adjust Refresh Rate enabled and whitelisting completely disabled for Kodi to automatically switch to the appropriate resolution.