Best TV Tuner for Vero/OSMC

That’s a shame. The 292e seems to be one of the few relativity cheap HD sticks around. Anyway you can see adding support in a future OSMC build without end users having to jump through hoops? After all Vero is aimed at end users not techies.

ordered from a company fulfilled by amazon so is covered with Amazons return policy which has been very good in the past.

although I have basic competency in terminal etc kernels / drivers etc is not something I have experience in (something im going to have to sort out soon)

but from what I have seen this is one of the only sticks that has a working driver for linux to support the HD signal if im not mistaken the almost all the other stick only support SD ? if thats right i would say this one is certainly worth trying to get it working.

unfortunately if I cant get EastEnders in HD I have no chance of selling this to my other half :smiley:

ill do some reading anyway and see what I can do but if anyone has the knowledge and willing to look into this as well id by happy to be your test dummy :smile:

I’m hoping Sam can help us and other potential 292e users out. It seems like the 292e would make a good addition to Vero/OSMC.

1 Like

Every tuner is going to require an element of ‘setup’ unfortunately, but it may not be as bad you think.

The ‘firmware’ install involves dropping the firmware file into /lib/firmware directory.

The driver can probably be built in to our kernels.

how did you get on?

at the moment its back in its box lol

I put allot of my ramblings as I went along on another post here:

the OP on that thread got it working well for SD tv on a RPI2 although were not exactly sure how but seems the kernal modules likely just needed enabling or the problems with the appstore version of tvheadend that may have caused his initial issues. last I heared he couldn’t get HD working though.
turns out both pi versions uses 3.18 kernel so drivers are atleast already in tree
on the vero front:
basicaly from what I can tell the kernel needs recompiling with the linux tv drivers found here:,_Build_and_Install_V4L-DVB_Device_Drivers

unfortunately it wouldn’t compile with all drivers and when tried to compile selectively I got it to compile but couldn’t get the modules to load due to duplicate issues etc.

further reading suggested a cross compile of the drivers may help but ive really hit my limit without any pointers from someone more experienced in this field. unfortunately sam hasnt come back I would image he is fairly tied up getting osmc final ect and nobody else has has jumped in so somewhat stuck at the moment but I live in hope :smile:, as it stands if you have a VERO DONT BUY THIS STICK

Thanks for updating us on your findings.

So much for Vero supporting ‘Most Tuners’ :confused:

1 Like

Vero does support most Linux tuners, but all of them will require an element of setup due to how scanning for TV channels works! Without access to everyone of these sticks however, universal support is tricky.

That said, without having one, this would probably work:

  • Get OSMC build tools
sudo apt-get install build-essential git
  • Get Vero kernel headers
set -- $(cat /proc/cmdline) && for x in "$@"; do case "$x" in osmcdev=*) sudo apt-get update && sudo apt-get install -y "${x#osmcdev=}-headers-$(uname -r)"; ;; esac; done
  • Get V4L and build it
git clone --depth=1 git://
cd media_build 
sudo make install
  • Now install the firmware:
sudo wget -O /lib/firmware/dvb-demod-si2168-02.fw
sudo wget -O /lib/firmware/dvb-demod-si2168-b40-01.fw
  • Now reboot.
sudo reboot


sam thanks for the reply, this seems very similar to what I had tried (but not exactly the --depth bit I know I didnt try) so ill try it out again and let you know
cheers pete

The --depth just gives you a quicker checkout by getting a more condensed version of the repository’s history


@sam_nazarko seems we were on the same path Im back at the point I got stuck on last time trying a full build

so I had to install these

sudo apt-get install patch patchutils sudo apt-get install libproc-processtable-perl
then after headers installed had to do this:

cd lib/modules/3.14.14-7-osmc sudo ln -s /usr/src/vero-headers-3.14.14-7-osmc/ build
and then get ths error:

/usr/src/vero-headers-3.14.14-7-osmc/arch/arm/include/asm/io.h:305:0: note: this is the location of the previous definition #define writel_relaxed(v,c) __raw_writel((__force u32) cpu_to_le32(v),c) ^ CC [M] /home/osmc/media_build/v4l/flexcop-pci.o In file included from <command-line>:0:0: /home/osmc/media_build/v4l/compat.h:1563:0: warning: "writel_relaxed" redefined #define writel_relaxed writel ^ In file included from include/linux/io.h:22:0, from include/linux/pci.h:31, from /home/osmc/media_build/v4l/compat.h:1454, from <command-line>:0: /usr/src/vero-headers-3.14.14-7-osmc/arch/arm/include/asm/io.h:305:0: note: this is the location of the previous definition #define writel_relaxed(v,c) __raw_writel((__force u32) cpu_to_le32(v),c) ^ /home/osmc/media_build/v4l/flexcop-pci.c: In function 'flexcop_pci_write_ibi_reg': /home/osmc/media_build/v4l/flexcop-pci.c:100:2: error: implicit declaration of function 'writel' [-Werror=implicit-function-declaration] writel(v.raw, fc_pci->io_mem + r); ^ cc1: some warnings being treated as errors scripts/ recipe for target '/home/osmc/media_build/v4l/flexcop-pci.o' failed make[3]: *** [/home/osmc/media_build/v4l/flexcop-pci.o] Error 1 Makefile:1274: recipe for target '_module_/home/osmc/media_build/v4l' failed make[2]: *** [_module_/home/osmc/media_build/v4l] Error 2 make[2]: Leaving directory '/usr/src/vero-headers-3.14.14-7-osmc' Makefile:51: recipe for target 'default' failed make[1]: *** [default] Error 2 make[1]: Leaving directory '/home/osmc/media_build/v4l' Makefile:26: recipe for target 'all' failed make: *** [all] Error 2 build failed at ./build line 491. osmc@osmc:~/media_build$

I can disable that module in the .config file under v4l folder but the there is another that will fail in the same or similar way and they seem to just keep coming and coming ?

any suggestions ?

thanks pete

1 Like

@sam_nazarko, I think with the concept of the Vero, uses shouldn’t really be the ones going through all this hassles to get the tuner working. Also from research, this tuner seems to be one the best option for UK viewers wanting HD, it could also serve as a selling point that it works out of the box with specific tuners with HD capabilities. I will suggest making this work by default for Vero, Im almost certain, alot of buyers of Vero will have a very similar issue sometime in the future. By my estimation most users who eventually buy the Vero and want so TV experience will end up buying this tuner, as its probably the best option for now.

1 Like

I agree @deetu , Already tried to sell that concept to Sam but he didn’t seem interested.

Ade –

The amount of TV tuners out there: insurmountable. We do support quite a few as is out of the box, but we can’t support all of them.

Vero is very new, and supporting TV dongles will come in time, but we won’t have the resources to support all of them.

When working on Vero we considered adding a TV tuner to the device, but again, one size does not fit all. Some will want DVB-S and some will want DVB-T…

@phate1, by the way -Werror=implicit-function-declaration is not really an error, it is a warning turned to error. If you look for a file called Makefile in the directory, and remove the -Werror=implicit-function-declaration option, it will compile just fine and the tuner should work.

I’ll add kernel support for this if it’s cleanly backportable. I am sure the 292e can work with Vero ‘out of the box’


That great thanks Sam, early start tommorow so I’ll give that a shot tommorow evening and let you know how it goes.


Sam not quite there yet :smile:
so checking make files I couldnt fine the line:

osmc@osmc:~/media_build$ more Makefile | grep Werror osmc@osmc:~/media_build$ more v4l/Makefile | grep Werror osmc@osmc:~/media_build$

so looked for anything that included that string (not sure if this is right never used his before today )

 grep --color=auto -RnH '\-Werror-implicit-function-declaration 

gave me a list of only these files:


soooo …

tried this:

 sed -i 's/\-Werror-implicit-function-declaration/ /g' .*.cmd 

and re-run the grep command and I get no more hits, figure the ./build would re write them so just use make … but fails the same and i find all those files have the same -Werror-implicit-function-declaration again :cry:

any other ideas ?

cheers pete

Probably in /usr/src/vero-headers-3.14.14-7-osmc/Makefile


1 Like

well that got allot further but …

sdev->gpio_reset = devm_gpiod_get_optional(&client->dev, "reset", ^ /home/osmc/media_build/v4l/si4713.c:1463:10: error: 'GPIOD_OUT_LOW' undeclared (first use in this function) GPIOD_OUT_LOW); ^ /home/osmc/media_build/v4l/si4713.c:1463:10: note: each undeclared identifier is reported only once for each function it appears in scripts/ recipe for target '/home/osmc/media_build/v4l/si4713.o' failed make[3]: *** [/home/osmc/media_build/v4l/si4713.o] Error 1 Makefile:1273: recipe for target '_module_/home/osmc/media_build/v4l' failed make[2]: *** [_module_/home/osmc/media_build/v4l] Error 2 make[2]: Leaving directory '/usr/src/vero-headers-3.14.14-7-osmc' Makefile:51: recipe for target 'default' failed make[1]: *** [default] Error 2 make[1]: Leaving directory '/home/osmc/media_build/v4l' Makefile:26: recipe for target 'all' failed make: *** [all] Error 2 build failed at ./build line 491. osmc@osmc:~/media_build$

appreciate you keep coming back to this, must be close now


I think we are just looking to get the most popular UK HD version supported which you and @phate1 seem to be making headway on. As it’s been mentioned already this would be a selling point for Vero/OSMC.

Sounds good

I like the idea of Suntek cards. They don’t rely on a kernel module (independent of kernel) and so this gives them a bit more resilience and probably better support in the long run.

@phate1: looks like missing kernel config option. Will investigate post-RC2