Bitstream not working

Hi Sam,

I asked on Avforums last night about my bitstream not working, then I could get it working of a fashion by changing the channel count and going back to the movie, but it goes back to pcm as soon as I stop the movie.

I hope I`ve done it correctly but this should be the log for it

Thanks very much.


Hi Dave,

I’ve checked your logs.

I can see Atomic and Valerian and the City of a Thousand Planets.mkv are being played with passthrough successfully. Did your AV report that passthrough was being used when you played these files?

Just to confirm: OSMC would change the stream back to PCM when there is no film being played; as the menu sounds would be sent as two channel PCM. The passthrough light will only show when you are playing content that can be passed through.


As an aside, I can see you are on an old version of OSMC. It’s worth keeping up to date.

See Keeping your OSMC system up to date - General - OSMC

Hi Sam,

Yes I did spot it was on a July version so I did the update but it didn`t change the bitstream issues.

When I tried to get the Kodi logs it said it couldn`t retrieve the URL so I had to do it in the command line. I only have 5 films currently on the NAS and each has now played the audio correctly when I play it first after a reboot, power disconnect or change of channel count in the menu settings. But as soon as you stop the film and select another then you lose bitstream and only get pcm.

I don`t recall which film I tried when I was getting the logs but they have all worked at some stage until you stop it playing.


So if I understand correctly, passthrough works for each film.
But if you watch a film A with passthrough, stop it, and then put film B on, then you don’t get passthrough?

That is rather peculiar.

If you can get a debug log of that behaviour it should tell us why.

Can you confirm that the Speaker Layout is now set to Fixed and not Optimized?



Wouldn’t Optimised or Best match be better? Then it would adjust for each film.

Well – Dave wants passthrough to work. I have seen cases where Optimises / Best Match can cause problems (likely due to channel map layout).

I believe Fixed at 7.1 is the best solution for now

That has been the case when I could get it working on a film as soon as you stopped it the next film would lose bitstream, but in trying to get another set of logs I can not get bitstream working at all again.


This is the Kodi log for playing Atomic Blonde no bitstream, then playing Valerian no bitstream, then changing channel to 5.1 and going back to Atomic Blonde still no bitstream. Audio was set at fixed ( which removes passthrough selection )

Hope that helps.


This log is changing channel to 2.0 and optimised, play first film bitstream Dolby Atmos then stop and go to next film and lose bitstream.



Hi Dave,

Sorry for the late reply.

19:19:10.482 T:3655566320   DEBUG: FactoryCodec - Audio: passthrough - Opening
19:19:10.482 T:3867288560   DEBUG: CAMLCodec::SetSpeed, speed(1000)
19:19:10.483 T:3655566320   DEBUG: FactoryCodec - Audio: passthrough - Failed

That’s interesting. Can you paste a full set of logs when it happens again. The kernel log will give clues in particular.

This should also improve audio until the next update is released:

Go to My OSMC -> Updates -> Manual Controls
Under Apply Hotfix, enter: [deprecated]


Hi Sam,

I thought that hotfix had done it, I could play 2 different Dolby Atmos clips and then go to a DTS:X and bitstream was fine. It was only when I selected the fourth clip that lost the bitstream again. So I`ve done a full log as requested.


This correctly played 2 films in Atmos then on DTS:X and DTS:HD lost bitstream and just played static noise.

Thanks again for all your help.


Hi Dave,

I might have misunderstood you before.

I thought that when passthrough wasn’t working, you were receiving a PCM track instead of the HD audio bitstream. But it sounds like when this fails, you actually hear static; but your AV shows it as PCM. This would suggest that the stream is being sent, but the AVR isn’t being signalled in to the correct mode to interpret it correctly; and therefore tries to play it as PCM.

Unfortunately those logs aren’t debug logs, but you are on the right track with uploading the full set.


Hi Sam,

No you were correct with the audio, when bitstream doesn`t work I do get audio as pcm. But for some reason this morning when I did that test for the logs it came through as static noise. not done that before.

But, this evening Ive re-routed some hdmis to install the Vero permanently so Its now Vero -> Marantz AVP -> Lumagen, whereas before it was Vero -> Lumagen -> Marantz. I tested all the 5 films again and all of them bitstreamed audio correctly. I dont know what`s changed as I did try Vero directly into the Marantz in the previous tests and still got pcm audio.

So, touch wood, at the moment it works as it should. I will do some more testing tomorrow evening and add another couple of films and setup my libraries as I want them and skins etc.
Hopefully it will still behave itself, I really hope so as it was flawless when all the films worked !

Thanks a lot Sam.

1 Like

Keep us posted.

Hi Sam,

All seems fine now, everything I`ve tried including some new additions all bitstream perfectly.

Thanks again for all your help.


Glad to hear it.

Did you physically disconnect power? There is stuff kept in memory about HDMI connection, even if they are proxied through a video processor.

In any case the usual chain should be Source -> Amp -> Video Processor -> Display/Projector.

To go deeper into the problem. You carry audio and video on the same HDMI connection. When a format changes a restart of the HDMI Output of your Lumagen may happen and the Marantz doesn’t really know to handle it sometimes. The Lumagen thinks the Marantz is in the correct mode but it isn’t. And the Marantz waits for something. So they are “out of sync” to speak so and think they are in sync. Both devices need to “re-negotiate” their connection, but don’t know that they need to do this.

This is a common problem when you have a longer HDMI device chain for usually video processing. No one really to blame here.

Receiver vendors have ton of workarounds for specific scenarios in their firmware. Guess whatever happens is not covered here.

If you need to have the Lumagen before the Receiver you might try splitting audio and video HDMI intro different ports, run audio to the Receiver and Video to the display/projector. That might help, but can also cause different issues.

I had a similar problem about a decade ago with a DVDO Edge back then. In my case I had to plug a mediacenter into the Edge and not the receiver to solve basically the same issue you were seeing.

Oh boy did I hate the HDMI firmware on that Onkyo Receiver. Awesome device, but the software… And back then I had to find “back channels” for a firmware as well as getting the dongle to update the HDMI firmware. HDMI Firmware updates by customers where not supported. Well times changed as vendors learnt. And shipping that top shelf heavy receiver would have been painful and out of the question (could barely lift it).

The “JTAG Dongle” passed through many hands - someone in Canada created it initially and we passed it on in the AVS forum to the next in line. I think it crossed the globe many times.

Never buying Onkyo again. Currently on some cheap Denon, but using it only as a Preamp and switching center. Makes no sense anymore to buy expensive receivers if connections change every few years (now it’s 4K). Better cheap but only use it as a pre-amp and update when something nice you want integrated comes along.