Black screen 10 bit


#1

Today i changed my yamaha avr a820 to denon avr x4500h, the testfile lg chess (https://4kmedia.org/lg-chess-hdr-demo/) gave a black screen, while this first played direct on tv 2018 q9fn it didn’t, even not when i tested it in shop on another yamaha avrx-a1080 after adjusting tv and avr into 4k mode 1 and uhd color on.

Is this the same issue as mentioned here?

My new avr is not able to display 4k 60 hz/fps with this 10 bit 422 while yamaha seems to be able as my tv

Yamaha

TV

Avr x4500h

The ave is put to 4k enhanced and tv is uhd color set on.

I solved the black screen issue by enabling force 422. Is that the solution for this issue on denon, which i didn’t had on yamaha rx-a1080?

Rx Product Name: DENON-AVRHD
Manufacture Week: 0
Manufacture Year: 2018
Physical size(cm): 142 x 80
EDID Version: 1.3
EDID block number: 0x1
blk0 chksum: 0x75
Source Physical Address[a.b.c.d]: 4.5.0.0
YCC support 0x03, VIC (native 255):
ColorDeepSupport 0xb8 10/12/16/Y444 1/1/0/1
97 16 31 4 19 5 20 32 33 34 93 94 95 96 101 102 98 99 100 7 22 3 18 63 64 15 36 30 38 95 94 93 98 353 352 357 358
Audio {format, channel, freq, cce}
{1, 7, 0x7f, 0x07}
{7, 5, 0x1e, 0x00}
{2, 5, 0x07, 0x00}
{11, 7, 0x7e, 0x03}
{10, 7, 0x06, 0x03}
{12, 7, 0x7e, 0x03}
{9, 5, 0x02, 0x00}
{11, 7, 0x7e, 0x01}
Speaker Allocation: 0x5f
Vendor: 0xc03
MaxTMDSClock1 300 MHz
Vendor2: 0xc45dd8
MaxTMDSClock2 600 MHz
ColorMetry: 0xc3
SCDC: 1
RR_Cap: 0
LTE_340M_Scramble: 0
HDR DeepColor
checkvalue: 0x75910000
cur_VIC: 97
VIC: 97 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV422
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

420,10bit
420,8bit
444,10bit
444,8bit
422,10bit
422,8bit
rgb,10bit
rgb,8bit

422

480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz
2160p30hz
2160p25hz
2160p24hz
smpte24hz
smpte25hz
smpte30hz
smpte50hz
smpte60hz
smpte50hz420
smpte60hz420
2160p50hz
2160p60hz
2160p50hz420
2160p60hz420

2160p60hz

Supported EOTF:
Traditional SDR: 1
Traditional HDR: 0
SMPTE ST 2084: 1
Future EOTF: 1
Supported SMD type1: 1
Luminance Data
Max: 0
Avg: 0
Min: 0

current vinfo:
name: 2160p60hz
mode: 32
width: 3840
height: 2160
field_height: 2160
aspect_ratio_num: 16
aspect_ratio_den: 9
sync_duration_num: 2997
sync_duration_den: 50
screen_real_width: 1420
screen_real_height: 800
video_clk: 594000000
viu_color_fmt: 2

hdr info:
hdr_support 0x00000005
lumi_max 0
lumi_avg 0
lumi_min 0
sink_flag hdmi out

hdr master display info:
present_flag 0
features 0x0
primaries 0x0, 0x0
0x0, 0x0
0x0, 0x0
white_point 0x0, 0x0
luminance 0, 0


#2

I’m confused.

Sounds like you have the solution already.


#3

Correct, while on coreelec they fixed something in a driver, within osmc i see force 422. Not sure if this is the entire solution, as i can’t see if driver and force are the same. That’s why i asked confirmation. :nerd_face:


#4

I still don’t understand what you want confirming. We will normally output 4k50/60Hz at 420 and 4k24Hz at 444. Some TVs don’t like that and if I understand you correctly so do some receivers. If you force 422 and it works - fine. We have thought about making 422 automatic for recent LG TVs but that wouldn’t have helped you with your Denon and Samsung.

I can’t speak for CoreElec.


#5

It seems that selecting force 422 in systemmenu of osmc worked for this sample file of Lg.

I thought that this option might have forced something more. But it worked otherwise i had to return the avr to change for yamaha.


#6

It’s fine, I think you just have a quirky display or receiver


#7

the specs of the file are:

Commercial name : HDR10
Format profile : Main 10@L5.1@High
Codec ID : 36
Duration : 1 min 52 s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate : 59.940 (60000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 10 bits
Writing library : ATEME Titan KFE 3.7.3 (4.7.3.1001)
Color range : Limited
Color primaries : BT.2020

i matched the 4k formats of HDMI 2.0 standard:

image

and with my x4500h receiver and tv see above, and the all match. note that i have to put avr in mode 4k enhanced and tv in uhd color on, to be able to exchange 50/60 4k.

So why is my output to tv “black” when not having force 422 set to on, only when playing the mentioned sample file?

could that be a “quirky” cable, on my devices, from vero to avr or from avr to tv, because putting vero direct on tv with supplied cable didn’t force me to put set “force 422 to on”.

Sorry to bothering again about the issue, but i want to pinpoint this, cabling or avr (which is brand new)?


#8

We would need to put a HDMI analyser on your equipment to find out. You should not see any difference in picture quality with 422.


#9

spent again several hours with cables and vero.

moving vero to tv solved all issues, but that’s not what i want, because not sure if earc on tv is fully functional, while this is enabled via firmware on avr.

Putting cable back, moved the delivered vero cable between avr and tv and used new cable between vero and avr and testing force 422 to off.

that worked, sometimes and heard ticking sounds and block images, then i knew a cable must be the issue. so several changes of cables worked, now everything is working without the use of force 422.