Black screen after June update

I ran the latest update this afternoon, after which I now get a normally get a black screen. However, using Sybu remote on my phone, I can get the Confluence screen up if I use the OSD setting. This doesn’t give any of the menu names but does show a white line where the option would normally be and I can scroll up and down with it.
The visible area is just over a quarter of the TV screen and is positioned top left of the screen.

I can SSH into OSMC from my Mac.
Even when the screen is blank, I can still hear key presses from the TV speakers.

I have tried renaming/ recreating the guisettings.xml file & also tried

sudo systemctl stop mediacenter
mv ~/.kodi ~/
sudo systemctl start mediacenter

Neither of the above have made any difference.

Clearly something is working but something seems to have broken. I have noticed that before the update I was getting 1080p but it has dropped back to 720p.

Any suggestions as to what I might try to get the video working again?



Can you upload some logs with grab-logs -A?


OK - I’ll do that tomorrow when I get the chance.

Thanks, Sam.

1 Like

Hi Sam.

This morning, I thought I would test it again. Still no good.

I thought I would move it to another location & plugged it into my PC monitor. No problems with it at all.

Returned it to its usual location & ditto - it works fine now. Even seems to work again at 1080p.

All very curious!


PS I suspect but can longer prove, that it was the TVHeadend dongle that had been nudged & was no longer seated correctly in the USB socket, as I didn’t move that to the PC. I have reconnected it, though & it still works as expected.

I’m not sure why that would cause a black screen though.


I’m at something of a loss myself as to what caused it but as it’s cleared, I’m not going to worry about it any more!