Black screen after launching on raspberry pi 4

Hello everyone,

I’ve installed osmc on my rpb4 several months ago and everything was working. But yesterday when I started my raspberry nothing appears after the loading of osmc

Since I can this the system loading I’m sure that it has nothing to do with my HDMI cable. I tried so far to reinstall the system on my sd card with the 2022 version but also the 2019 one’s but nothing changes.

Also, I tried to plug ethernet cable to the rpb4 but it doesn’t appear to be connected…

Do you have any idea how I could solve my issue?

Thank you!

There is no 2019 version of OSMC for Pi 4

I suggest clarifying your device and the version you are installing, and supplying logs where appropriate

Hello Sam,

My bad I misread the name of the versions, to be clear I’ve tried to reinstall using the three following ones:

Release Checksum (MD5)
2022.03-1 8667102004a5afdcc4a6e730f1fd2a96
2021.12-1 f19714cf2319e35891422631fb4cbd75
2021.11-2 694d988fd8ee911ccbfd17fd51d7f7e3

My device is: Raspberry Pi 4 Model B with 4gb ram (Broadcom BCM2711 64-bit ARM Cortex-A72 ( ARM v8 ) SoC with four cores at 1.5GHz)

I’m sorry but I didn’t find how to extract logs without using ssh and since I don’t find my raspberry on the network while it’s plugged in ethernet I don’t find how to find them.

Nevermind, I’ve found the cause.

It seems that the power charge supplied by the vendor wasn’t working after several months. I’ve changed to my mac charger and OSMC starts.

Do I need to buy a specific or I can use my mac one’s?

Thank you!

Your question would be better put on RPi forums. AFAIK any USB-C supply able to provide at least 2.5A will do it.

Any USB-C should be fine. Some earlier Pi 4 models had issues with USB-C chargers from Mac. This didn’t damage the device – they simply couldn’t be powered by them due to a negotiation issue.